Clean Software Update Groups console extension for ConfigMgr

Console extension for ConfigMgr for cleaning up Software Update Groups automatically using PowerShell.

 
 
 
 
 
4.8 Star
(26)
10,791 times
Add to favorites
System Center
5/27/2016
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Does this thing still work?
    3 Posts | Last post September 12, 2019
    • Seeing that this was last updated in 2016, and the most recent question was answered by someone back in September, I am a little hesitant to use this script.  Does anyone know if it will still work on CM1902?  I wonder if I will get an answer?
    • Hi CSD-EL,
      
      I tried it on 1902 and the script doesn't seem to work for me. It installs ok and I can see the context menu, but script errors out (red text in powershell window) and auto closes. I'll have to investigate further, but at this stage it doesn't 'just work'.
    • Hi Nutshell30,
      
      Thank you for replying and letting me know.  Please let us all know if you can get it to work somehow.
      
      Best regards
  • How do I uninstall it?
    1 Posts | Last post August 26, 2019
    • This tool does not work, how do I uninstall it?
  • Multiple Site Servers
    1 Posts | Last post May 24, 2019
    • I have multiple site servers I connect to. How do I specify this when installing your script?
  • Blue Powershell Flashes
    1 Posts | Last post January 18, 2019
    • Nickolaj
      If I run the script from within and elevated ISE council its runs but if I right click and run from the SCCM interface it quickly flashes a powershell screen I see a flicker of a red erros and then closes? The xml is where it should be. What am I doing wrong?
      Cheers!
      
  • CAS01
    1 Posts | Last post September 13, 2018
    • Not sure what I'm doing wrong here.  I have tried both the hostname and FQDN of my siteserver, but each time the XML shows "-SiteServer CAS01" and the extension does not show up in the context menu.
      
      Running both PowerShell and ConfigMgr Console as Admin.
  • Security ROle to have access to this tool?
    1 Posts | Last post September 06, 2018
    • Hello,
      
      What is the security role necessary to run this tool?
      or what are the permissions needed to be able to get this right click?
      
      For now only the Full Admins have access to it. Not even all administrators could see it!!! Only the one (also the installer) with the Assigned Scopes set to "All" not the ones with "Default". 
      
      Thanks,
      Dom
      
  • error when running script
    2 Posts | Last post September 06, 2018
    • Hi 
      I CB1706 on server 2016
      when running the script in elevated powershell I get the following error:
      
      C:\Users\peterpan\Desktop\cleansoftwareupdategroups\Invoke-ToolInstallation.ps1 : Cannot validate argument on
      parameter 'Path'. Unable to locate part of or the whole specified path, specify a valid path
      At line:1 char:75
      + ... on.ps1 -siteserver SCCMpr1 -Method Install -Path C:\Scripts -Verbos ...
      +                                                        ~~~~~~~~~~
          + CategoryInfo          : InvalidData: (:) [Invoke-ToolInstallation.ps1], ParameterBindingValidationException
          + FullyQualifiedErrorId : ParameterArgumentValidationError,Invoke-ToolInstallation.ps1
    • Late to answer this, but open PS or PS-ISE as admin, cd to where the install script is, and run the following command:
      
      powershell.exe -ExecutionPolicy Bypass -file Invoke-ToolInstallation.ps1 -SiteServer yourserver.domain.com -Method Install -Path C:\ScriptLocation -Verbose
      
      Change ScriptLocation to where you want the script to be copied to (and make sure it exist first), change yourserver.domain.com to your FQDN for your SCCM server, and it should install. I'm running on 1806 and it is working fine.
  • plugin not showing up
    3 Posts | Last post September 06, 2018
    • used the install scrips from a admin PS window, checked the 23e7a3fe-b0f0-4b24-813a-dc425239f9a2 folder, the XML looks good with all the right server and file paths, but when i relaunch the SCCM counsel, the plugin is not showing...
      
      any ideas?
    • You prob need to place the xml under ...\AdminConsole\XmlStorage\Extensions\Actions\23e7a3fe-b0f0-4b24-813a-dc425239f9a2
    • Try also running the console "as admin", even if your account is in the local admin/domain admin group, and if your user in SCCM has full administrator rights.
      
      Some third party plugins, and this script included requires the console to be run as admin.
  • Permissions
    1 Posts | Last post September 06, 2018
    • As a full administrator I am able to see this excellent tool after installation. But the Patching Admins do not see it. Which permissions doe they need? They have access to all scopes.
      There have 
      Software Update Group: Read, Modify, Delete, Set Security Scope, Create
      Software Update Package: Read, Modify, Delete, Set Security Scope, Create
      Software Update : Read, Modify, Delete, Create, Move Object, Modify Folder, Network Access, Run Report
      
      Thanks,
      Dom
  • Doesn't Run
    1 Posts | Last post May 04, 2018
    • Hello,
      
      I have installed this but when I run it in the Console I get a quick blue Powershell screen that flashes and that is it.  Am I missing something?
1 - 10 of 18 Items