ConfigMgr OSD FrontEnd 1.6.0

ConfigMgr OSD FrontEnd has been developed with the goal to function in any environment, making the native operating system deployment experience with System Center Configuration Manager more unified and easier to use.

 
 
 
 
 
4.8 Star
(19)
10,286 times
Add to favorites
System Center
7/5/2019
E-mail Twitter del.icio.us Digg Facebook
  • Problems installing applications with OSDFrontend
    2 Posts | Last post February 27, 2020
    • Hi, I'm having trouble getting the applications to install during the OSD.
      The applications shows up fine in the Frontend and when selected, they obviously appear in the APPLICATION variable in the TS.
      I have changed the variable in the TS to correspond to the OSDFrontend configuration.
      I can see that it successfully tries to install my test-application (which is really just a script that copies a textfile to a c:\temp\ folder, first creating C:\temp of course.
      It fails however with the usual 80040005 error which could mean anything.
      Doesn't seem to enter the script, it doesn't even create c:\temp.
      
      When deployed individually to a computer and run from software center, the script works fine.
      
      Any ideas?
    • Not entirely sure if it's the same issue, but I had problems installing applications in general.
      
      Since January 2020 we suddenly had a issue when installing a application while in a OSD. We deploy OSD's cross forest. In order for SCCM to find his MP we defined srv records in the forest pointing towards their MP. This sadly didn't work anymore.
      
      We extended the Active Directory of each forest and published our site information to them. this fixed the issue for us. Hopefully this is a solution for you.
      
      Otherwise try to place a extra commandline step after "Setup Windows and ConfigMr with the following command:
      
      msiexec.exe "C:\Windows\ccmsetup\{D28E1200-1800-43EF-ACB8-BDAB05E7C196}\client.msi" SMSMP=YOURMP SMSSITECODE=YOURSITECODE /qb
      
      This basicly reinstall the client pointing to the given MP. Noteworthy though to say, the client will leave provisioning mode, so client policies will be pushed.
      
      Note: {D28E1200-1800-43EF-ACB8-BDAB05E7C196} will be different based on your SCCM version you're running. Check the directory C:\Windows\ccmsetup\
      
      I hope this will help you in your case. If not, maybe there is something else going on.
  • Application Selection Only
    1 Posts | Last post January 23, 2020
    • Is it possible to modify the frontend to show application tab only? The reason I ask is for refresh scenarios where the frontend is run from the TS while in full OS, so user can select optional software.
  • Supported Hardware
    1 Posts | Last post January 11, 2020
    • Even though I entered the model name in the text document and redistributed the boot images, the Preflight Check still fails on that check. This fails for both VMware Virtual Platform and  Alienware Area-51m. Are these supported in the application?
  • No Tasksequences displayed
    2 Posts | Last post January 08, 2020
    • I'm having trouble with a fresh install of Webservice 1.8 and OSDFrontend 1.60.
      
      The frontend comes up just fine and also gets the correct computername from MDT database via call to GetMDTComputerByName, even tried calling the webmethod directly from powershell and it works fine.
      
      However, no tasksequences are visible at all in the OSDFrontend. Doublechecked that my TS is indeed deployed as hidden to media and PXE only to All unknown computers.
      When calling GetCMHiddenTaskSequenceDeployments, it also shows up blank.
      
      Suspects that it's the webservice that does not work correctly. Noticed that alot of the other methods does not work either.
      Tried GetCMTasksequence, GetCMCollectionByName and GetCMHiddenTaskSequenceDeployments which all turns up blank, while GetMDTComputerByName and GetADComputer works fine for instance.
      
      Any ideas with this?
      
    • Actually found the answer when I read what i had written.
      No CM-related webfunctions worked.
      Had forgotten to add the webservice account permissions in SCCM of course :)
      
  • Unknown Devices - DeployRestrictTaskSequenceSelection
    3 Posts | Last post January 06, 2020
    • Question, are all task sequences supposed to be shown in the drop down list even if “DeployRestrictTaskSequenceSelection” is set to true when the device is detected as UNKNOWN?
      
      When I debug from a known machine, I get the correct task per the user’s group. I can also see it check each task against what’s approved in the Logs. But on an unknown machine, it always list all available task sequences. In the logs, it shows that it finds what’s supposed to be available per the user’s group, but afterwards it goes into device detection, detects the device as unknown and then list all task sequences.
      
      Couldn’t find the answer to this in the documentation, hoping to find it here.
    • Digging a little more, I see that I'm having an issue with the web service.  Seeing this error in the event manager "An error occured when attempting to locate Active Directory object. Error message: The specified domain either does not exist or could not be contacted." I'm stumped at this point.  Anyone able to offer any advice? 
    • Yes, same issue here. Our Webservice seems to be fine though. (1.8.0)
  • DeployConfig.xml
    3 Posts | Last post January 06, 2020
    • We're having trouble with DeployConfig.xml and DeployRestrictTaskSequence = True.  When i set these values, the logfile shows that it is getting the restrictions file successfully, but my test computers still show all available task sequences, despite the user being limited to one task sequence...
    • We also have the same issue - not sure whether there's a configuration issues on our side or whether it's a bug. I don't recall it working in 1.4 either. 
    • We also have this issue. No matter how DeployConfig.xml is configured, all TS are shown in the dropdown.
  • Moving computer to OU
    1 Posts | Last post November 22, 2019
    • Hi Nickolaj
      
      I got an issue using SCCM frontend.
      
      I'm no able to move the computers to the correcto OU using the Front End option panel.
      
      Must be this TS Variable informed at unnatend.xml ?
      
      How could I check what I'm doing wrong ?
      
      Kind regards
  • Unable to load configuration file
    4 Posts | Last post November 21, 2019
    • Hi,
      
      The message "Unable to load configuration file for regional setting" always appears. I have the config-file in the same place as the OSDFrontEnd.exe and additionally in "http: //xxxx/ConfigMgrWebService/RegionalConfig.xml". No matter if I leave the item "RegionalConfigFileLocation" empty in OSDFrontEnd.exe.config or write "http: //xxxx/ConfigMgrWebService/RegionalConfig.xml" into it the error message always comes up. The URL is easily accessible in the browser.
    • chipDE,
      
      If you don't need to use the region file just set the flag "IsRegionalEnbaled" to false in the OSDFrontEnd.xexe.config
      
      I had the same issue and didn't need to utilise such feature so bye bye it went.
    • Hi guys,
      
      I'm unfortunately unable to reproduce this error when debugging. I have the RegionalConfig.xml in the root dir of the frontend but a proper URL is also configured for RegionalConfigFileLocation. Could you share a bit more on how to reproduce this?
      
      Regards,
      Nickolaj
    • Hi ChipDE,
               Make sure you copied all your config files to C:\inetpub\ConfigMgr WebService Where in OSDFrontEnd.exe.config file you do call out all the source location based on the IIS url not based on the local path.
      
      Regards,
      Prabha
  • Supported HWModels.txt
    1 Posts | Last post November 13, 2019
    • Is it possible to have the option for the FrontEnd to check against the ConfigMgr Webservice, https://www.scconfigmgr.com/configmgr-webservice/, for supported hardware models instead of using HWModels.txt
      
      This would help for Lenovo computers where you could support a ThinkCentre M900, but the driver pack doesn't support all sku's of that model.
  • Restarted workstation when authentication attempt
    1 Posts | Last post November 01, 2019
    • Hello. Many thanks for your development.
      We use ConfigMgr OSD FrontEnd with the step of pre-authentication of the user. There is an Active Directory group with several hundred authorized users to perform deployments. For the vast majority of authorized users, the authentication process and subsequent deployments occur perfectly, except for a single account. At the moment of authentication attempt (Checking group membership for authenticated user) the workstation is restarted. OSDFrontEnd.log file reports a successful user verification and ends with:
      	Authentication: Authenticated user is a member of specified group;
      	Authentication: DeployRestrictTaskSequenceSelection setting enabled, querying for group memberships for authenticated user.
      smsts.log file contains an error entry:
      	Process completed with exit code 3762504530;
      	uExitCode == 0, HRESULT=80004005 (tsmediawizardcontrol.cpp, 545);
      	'OSDFrontEnd.exe' returned error: 0xe0434352;
      	Successfully unregistered Task Sequencing Environment COM Interface.;
      	Authenticator from the environment is empty.;
      	Need to create Authenticator Info using PFX.
      
      The working environment is SCCM CB 1906 with ADK 10. Please help solve this problem.
1 - 10 of 79 Items