ConfigMgr OSD FrontEnd 1.6.0

ConfigMgr OSD FrontEnd has been developed with the goal to function in any environment, making the native operating system deployment experience with System Center Configuration Manager more unified and easier to use.

 
 
 
 
 
4.8 Star
(19)
10,338 times
Add to favorites
System Center
7/5/2019
E-mail Twitter del.icio.us Digg Facebook
  • DeployConfig.xml
    2 Posts | Last post July 25, 2019
    • I am just trying to figure out the functionality. How does the Task sequence selection works out. What should i change in DeployConfig.xml??? How to make it appear in the Front end????
      Thank you noobs
      
      
    • Is this actually a serious question?  Cannot tell from how you phrased it...
      
      All of that is described pretty thoroughly in the Documentation that is included in the download.
  • Applications and Task Sequences
    7 Posts | Last post July 17, 2019
    • How do i get applications and task sequences to show up in the front end?
    • Figured out the Task Sequence piece but I still can't get apps to populate!
    • Lol... figured out the missing apps!
    • Any chance you can answer how you got it working? I am running into the same problem.
    • yep im curious too? i cant seem to get off the ground with this one? would you be able to do like a YouTube video or document? i don't find the one included to be all that clear 
    • Read these sections in the documentation:
      
      4.10
      4.10.1
      4.10.2
      9.8
      
      Mine is setup as followed, as an example:
      In the OSDFrontEnd.exe.config i use "APP" as "AppsTaskSequenceVariableName"
      
      I choose to place the "AppConfig.xml" on a server so that i can edit it without the need to update the bootimage, and point this out in the OSDFrontEnd.exe.config. I placed them in a new folder under the ConfigMgrWebService, as this is already availible to reach when you PXE/OSD.
      
      And then, when you have got your config done, you need some apps to show up. as an example i have VLC. What you need to do with the application in SCCM is to add an "Administrative Categories" to it, i chose "Video" (its up to you what you want to call it).
      After that, you go to the "AppConfig.xml" and you add this line:
      
      <AppCategory Name="Video" AdminCategory="Video" IsSelected="False"/>
      
      Now VLC will show up as selectable.
      
      My whole "Appconfig.xml" looks like this for the moment:
      
      <AppConfiguration>
        <AppCategory Name="Webb" AdminCategory="Webb" IsSelected="False"/>
        <AppCategory Name="Video" AdminCategory="Video" IsSelected="False"/>
        <AppCategory Name="Verktyg" AdminCategory="Tools" IsSelected="False"/>
        <AppCategory Name="TeamViewer" AdminCategory="TeamViewer" IsSelected="False">
      	<AppSelection Name="TeamViewer 14 Host" Mandatory="False" IsSelected="True"/>
      	<AppSelection Name="TeamViewer 14 Host RTOG" Mandatory="False" IsSelected="False"/>
      	<AppSelection Name="TeamViewer 14 Host Visualiseringsbord" Mandatory="False" IsSelected="False"/>
      </AppCategory>
        <AppCategory Name="Standard" AdminCategory="Mandatory" IsSelected="False">
      	<AppSelection Name="HP Hotkey Support" Mandatory="True" IsSelected="True"/>
      	<AppSelection Name="BGinfo Admin Win10" Mandatory="True" IsSelected="True"/>
      </AppCategory>
      </AppConfiguration>
      
      
    • In your task sequence you have to do the following:
      
      Add an "install application" step, and check the "install applications according to a dynamic variable list" radio button, and in the text-box bellow, enter the "AppsTaskSequenceVariableName" variable that you choose (mine was APP). 
      
      and that is all you have to do.
      
      Happy to help if more is needed! :)
  • Moving computer objects in AD
    2 Posts | Last post July 17, 2019
    • Hi,
      
      I'm having problems with the frontend and AD computer-objects.
      If there isnt a preexisting object in the AD the FrontEnd creates it under th OU which i choose under the Directory tab, but if the object is already created and placed under an OU and i choose a different OU it doesnt get moved.
      
      Is this as intended? Do i have to remove the AD-object each time if i want it placed somewhere else, or is something not working? 
      
      The ConfigMgrWebservice account has full control over the OU and all object under it, ive even tried given it Domain Admin rights, same result.
      
      Any ideas?
      
      best regards,
    • This has been answered somewhere else. 
      
      Short answer:
      The frontend only joins the computer to the selected OU if the object doesnt already exist, and it gets created.
      If theres already an compute-robject for the device in another OU, the object wont be moved, it will stay in the same OU.
  • Prestaged media ?
    2 Posts | Last post June 18, 2019
    • Hello there,
      I usually use this marvelous frontend with pxe but my boss requested me to provide a prestaged version of our master to a supplier. I already generated a huge wim file but never succeeded to apply it correctly. It starts the standard windows setup instead. Do anyone of you knows a good blog speaking about this ? Regards, frederic
    • By the way, I followed this to apply the wim file in win pe:
      https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/capture-and-apply-windows-using-a-single-wim
  • Issue with 1903 ADK
    2 Posts | Last post June 12, 2019
    • Anyone else having a problem with the front end crashing immediately and rebooting the machine when using the 1903 ADK?
    • Is this due to the removal of WPF from the ADK? 
  • Dynamic OS
    3 Posts | Last post June 05, 2019
    • Would be awesome if instead of (or in addition to) choosing from different task sequences, you could choose a different OS image
    • Hey Scott, Have you had any success setting up the frontend? if so, how do you configure the task sequence for use with the frontend?
    • You want to deploy the task sequences as available to "Only media and PXE (Hidden)". Must be hidden.
  • Task Sequence?
    1 Posts | Last post May 29, 2019
    • How do you configure the task sequence for use with the front end?
  • Issue with Application Selection
    4 Posts | Last post May 21, 2019
    • Not sure if anyone else has this issue, if IsSelected is set to true for an application in the AppConfig.xml, the application shows checked in the OSD application tab but it will not load the application into the variable. You have to uncheck it then recheck it for it to load into the variable.
    • Hi,
      
      Yes, same problem here.
      The apps i uncheck/check gets picked, or if i check any of the apps which is not selected from start.
    • We have the same issue in our environment 
    • Hi, I also noticed this problem. 
      
      If IsSelected="True" are set in “AppCategory Name” it will not work.
      
      Workaround are either:
      - Uncheck and check manuel
      - In “AppCategory Name” set IsSelected="False" and create individual “AppSelection Name” for each SCCM Application there need to be prechecked with both Mandatory="True" and IsSelected="True". The downside is prechecked applications can be deselected.
         - Please not that setting IsSelected="True" in “AppCategory Name” and Mandatory="False" in “AppSelection Name” will not work.
      
      This will work and set the corrects “APPLICATIONxx” (defined in the OSD variable “AppsTaskSequenceVariableName”)
      
      (Issue seen in “ConfigMgr OSD FrontEnd 1.5.1” running with “ConfigMgr WebService 1.7.0”.)
      
      Thanks for at great tool to SCCM 😊 just love it and the way it’s build.
      
  • OSDFrontEnd with Stand Alone Media
    2 Posts | Last post May 17, 2019
    • Has anyone created stand-alone media that includes the OSDFrontEnd with success?  I was able to create a bootable flash drive, boot from USB, OSDFrontEnd loads, select all the options I want, but when I start the process I get an error that says "Unable to load the TS Environment" and my task sequence never starts.
    • My stand-alone media has the OSDFrontEnd and works normally. What I do is have my Boot Image configured normally with the OSD FrontEnd included (as part of the standard Boot Image, not part of the standalone). I then build stand-alone media set to run unattended without any additional files or configuration. The unattended means that it runs the FrontEnd without stopping for manual network configuration. Not including OSDComputerName or other things means that scheduled jobs don't get messed up.
  • ERROR: User not authorized for deployment
    3 Posts | Last post April 30, 2019
    • I have configured two child domains into the OSD Front End xml file, however when I try and authenticate with a user in the child domains i get a ERROR: User not authorized for deployment even thou I've placed the users in the child domain into the groups configured in the XML.
      
      Is there anything that needs to be configured to allow auth from users in child domains?
    • I'm getting the same error but on my primary domain.
    • Discovered that the password for the account running the ConfigMfrWebService had changed passwords.  Updated that and restarted the app pool and authentication started working.
      
      Make sure the account you use for the app pool has permissions in both domains.
21 - 30 of 79 Items