ConfigMgr OSD FrontEnd 1.6.0

ConfigMgr OSD FrontEnd has been developed with the goal to function in any environment, making the native operating system deployment experience with System Center Configuration Manager more unified and easier to use.

 
 
 
 
 
4.8 Star
(19)
10,338 times
Add to favorites
System Center
7/5/2019
E-mail Twitter del.icio.us Digg Facebook
  • App in debug mode crashes on startup. .Net version?
    5 Posts | Last post February 20, 2019
    • As the title says, when I try to run the app standalone, with the debug switch, the app crashes. It loads modules and then it crashes. In the event viewer I get this:
      Faulting application name: OSDFrontEnd.exe, version: 1.4.0.0, time stamp: 0x5b2c113f
      Faulting module name: KERNELBASE.dll, version: 6.3.9600.18938, time stamp: 0x5a7ddf0a
      Exception code: 0xe0434352
      Fault offset: 0x0000000000008eac
      Faulting process id: 0x3140
      Faulting application start time: 0x01d42fe09d4cba59
      Faulting application path: C:\inetpub\ConfigMgr WebService\OSDFrontEnd.exe
      Faulting module path: C:\Windows\system32\KERNELBASE.dll
      
      Any idea?
    • I had the same problem. I didn't have .NET Framework 4.5 runtime installed. 
    • You'd need to have .NET Framework 4.5.1 or higher installed.
      
      Regards,
      Nickolaj
    • Also getting this exact issue, attempting to run debug from multiple PCs and from our Server. All have .Net 3.5 and 4.7. 
      
      
      Faulting application name: OSDFrontEnd.exe, version: 1.4.0.0, time stamp: 0x5b2c113f
      Faulting module name: KERNELBASE.dll, version: 10.0.17763.292, time stamp: 0xb51bba8e
      Exception code: 0xe0434352
      Fault offset: 0x0000000000055549
      Faulting process id: 0x3f0
      Faulting application start time: 0x01d4bf05b0b4938e
      Faulting application path: C:\inetpub\ConfigMgr WebService\OSDFrontEnd.exe
      Faulting module path: C:\Windows\System32\KERNELBASE.dll
    • I had a similar issue with the App crashing in debug mode.  I found there was an issue with my .xml file.  After looking it over I resolved the issue by removing the '&' from the name of one of my mandatory applications.  Try looking at your xml and see if you have any formatting issues or typos?
  • Error No Network
    2 Posts | Last post January 14, 2019
    • Hello Nickolaj.
      We have an issue when we try to network boot HP Zbook 15 G5 Mobil to our OSD, it says no network just before the OSD is starting up (i've added the LAN driver in win pe) but still no luck
    • Hi,
      
      Have you tried to increase the TestWebServiceTimeout setting? If that's not what's causing it you should probably look into why you're machines are not getting an IP at that point as it normally should.
  • Computer not renaming
    3 Posts | Last post January 10, 2019
    • Anyone else running into an issue where the value entered on the computer name tab is not being passed to the Apply Network Settings task?  All my unknown machines end up being WINIT-XXXXXX regardless of what I enter for a computer name in the front end.
      
      I do have OSDComputerName as a collection variable on my All Unknown Systems collection.
    • You shouldn't have that value configured, that's most likely what's causing the issue for you. The frontend will take care of settings the OSDComputerName variable with the value entered in the text box.
      
      Regards,
      Nickolaj
    • You are correct, sir.  I removed it from the collection and it started working.  In fact I think it fixed some other issues that were cascaded from the failed rename.
      
      The setting was leftover from my configuration prior to implementing the front end.  Thanks for the quick response.  And keep up the great work!
  • Few Feature requests
    2 Posts | Last post January 10, 2019
    • Hi Nickolaj,
      
      Is it possible to have pre-flight skipped if all checks return OK?
      
      Also, Is it possible to reference the default config file from a web server to enable on the fly changes/updates as opposed to updating the boot image? maybe a /config:http://site.fq.dn/app/config.xml flag and maybe a fallback config too if the primary is unavailable (Feature is available in UI++ for example).
      
      Could we also in the AppConfig.xml specify if a group is Mandatory and maybe even put a specifier on their like if ChassisType=Laptop then mandatory etc. This could help reduce the need to manually update the main config file with mandatory apps if we can config as part of the apps specification. The mandatory lock should still have the same effect on these apps too.
      
      Thanks,
      
      Marcus
    • Hi Marcus,
      
      Pre-flight will get a facelift in version 1.5.0 with a datagrid instead of the stackpanels and rectangles used today. I'll add this to the list but unsure if I can make that with 1.5.0.
      
      Unfortunately that's not possible with the OSDFrontEnd.exe.config file, it has to be in the same directory as OSDFrontEnd.exe.
      
      That's planned for a future release with the mandatory groups for applications. Mandatory applications will be moved from the OSDFrontEnd.exe.config file into a new xml file that's possible to put on a webserver.
      
      Regards,
      Nickolaj
  • Windows Authentication bug?
    2 Posts | Last post January 10, 2019
    • Hello Nickolaj!
      
      Thank you for this really great tool! However, when I configured the Front End 1.4.0 (with webservice 1.6.0) in my lab env, I came across a possible bug during the Windows authentication step. It works fine if I enter my domain account and a correct password. It authenticates me and passes me to the next step. If the password is incorrect, the Front End hangs for a while and then the computer reboots. Is this a known issue? 
      
      Regards, Christian 
    • Hi,
      
      This has been fixed in version 1.5.0 that will be released very soon, stay tuned!
      
      Regards,
      Nickolaj
  • Only applications?
    2 Posts | Last post January 10, 2019
    • Great tool this frontend!
      I was wondering, we have a TS which is working great but we are looking for a tool which only gives a list of extra applications ready to install.
      Is this possible with this frontend?
      
      We already are using the driver management tool so the webservice 1.6 is already installed. We have Win7 and Win8.1 ready to migrate to Win10.
      ADK 1809 with CM 1806
    • Hi Michael,
      
      Sorry for the late reply. Currently with version 1.4.0 it's not possible to only use the frontend for a single purpose, like using the application section only. I'm thinking of enabling this for future versions, but there's quite a lot of code to refactor to support this. It's however on my todo list, but with no commitment yet.
      
      Regards,
      Nickolaj
  • Error in smsts.log when starting OSDFrontEnd.exe
    6 Posts | Last post January 10, 2019
    • Hi there Nikolaj or anyone else using OSD FrontEnd 1.4.0.  I'm getting error 'OSDFrontEnd.exe' returned error: 0x000000ff in the smsts.log in PE environment.  
      
      The symptoms I have is the VM just starts and OSDFrontEnd.exe never starts and when I view the smsts log this is the error thrown.  I do have have WebService 1.6.0 installed.
      
      Any suggestions would be appreciated.  What I've done so far.
      
      Re-download OSDFrontEnd
      Re-install WebService
      Repair WebService
      Removed Boot Image and create a new one.
    • I wanted to check if this has something to do with perhaps the ADK and WinPE 1809 updates?  Paging Nikolaj :)
    • Fix to the issue posted here by Martin Bengtsson https://www.imab.dk/workaround-fixing-crashing-wpf-forms-in-powershell-after-updating-to-windows-10-adk-v1809/ 
    • The fix on Martin Bengtsson's site works like a champ.
    • Thank you so much for this!!!
    • This should be the proper solution on how to fix issues with the frontend and ADK 1809:
      
      http://www.scconfigmgr.com/2018/11/23/fix-windows-adk-version-1809-issue-with-crashing-wpf-applications/
      
      Regards,
      Nickolaj
  • New system in ConfigMgr = Empty Computer Name
    3 Posts | Last post January 10, 2019
    • For some reason the frontend leave the Computer Name blank when we freshly imported a system into Configuration Manager. When we click on Details on the Computer tab all the needed information is there including the unique identifier we use (MAC Address). If we click next we see the advertised Task Sequences and after clicking Apply the frontend kicks off the correct TS and the system is being deployed with the name it is known by in Configuration Manager.
      
      When the deployment is succesfully finished and after doing some testing we kick of the PXE deployment again with the frontend and this time the Frontend displays the name in the Computer Tab.
      
      I don't know if we are the only one experiencing this issue. I guess it's easy to reproduce. Just import a new system into Configuration Manager with the MAC address as the unique identifier and start the system via PXE boot. First time system name is blank, all other times the name is correctly retrieved from Configuration Manager.
      
      Our detection method:
      
      <setting name="ComputerNameBySerial" serializeAs="String">
                      <value>False</value>
                  </setting>
                  <setting name="ComputerNameByScript" serializeAs="String">
                      <value>False</value>
                  </setting>
                  <setting name="ComputerNameFromMDT" serializeAs="String">
                      <value>False</value>
                  </setting>
                  <setting name="ComputerNameFromCM" serializeAs="String">
                      <value>True</value>
                  </setting>
                  <setting name="ComputerDetectionType" serializeAs="String">
                      <value>MacAddress</value>
                  </setting>
      
      Anyone else experiencing this issue? We use Configuration Manager Current Branch 1802 with ADK 1803. All seems to be working fine. 
      
    • Thank you for reporting this, I'll try to reproduce it and include a fix in version 1.5.0.
      
      Regards,
      Nickolaj
    • I've found the issue and a fix has been implemented, would you mind sending me an email at nickolaj@scconfigmgr.com and test out the fixed version?
      
      Regards,
      Nickolaj
  • Error message
    3 Posts | Last post January 10, 2019
    • I have configured a few options in the "OSDFrontEnd.exe.config" file and now when I attempt to chk the config by running "OSDFrontEnd.exe debug" I get the following error message:
      "Unsupported accent for application theme detected" and I have no idea what this means. I would guess by the error it was something "theme" related, but I've made no changes to the "theme" and/or interface for the frontend as of yet. Stumped!
    • Hello,
      
             You'll have to edit the OSDFrontEnd.exe.config. Change what you have currently in your config to make it match the following:
      
      <setting name="UIAccent" serializeAs="String">
                      <value>Blue</value>
                  </setting>
                  <setting name="UITheme" serializeAs="String">
                      <value>BaseLight</value>
                  </setting>
    • DrChuck is right, in the documentation there's a list of the supported values for these two settings.
      
      Regards,
      Nickolaj
  • OSDFrontEnd.exe debug not working remotely
    2 Posts | Last post January 10, 2019
    • When I run OSDFrontEnd.exe debug from a remote machine the Deployment section doesn't show any Task Sequences. 
      
      When I run OSDFrontEnd.exe debug from the SCCM server everything works for the OSDFrontEnd including the Deployment sections.
      
      Any fix for this type of problem?
    • Could it be that the remote machine you're running it from exist in ConfigMgr with a record but does not have any hidden task sequence deployments targeted?
      
      Regards,
      Nickolaj
41 - 50 of 79 Items