ConfigMgr OSD FrontEnd 1.6.0

ConfigMgr OSD FrontEnd has been developed with the goal to function in any environment, making the native operating system deployment experience with System Center Configuration Manager more unified and easier to use.

 
 
 
 
 
4.8 Star
(19)
10,339 times
Add to favorites
System Center
7/5/2019
E-mail Twitter del.icio.us Digg Facebook
  • Deployment feature
    3 Posts | Last post May 18, 2018
    • First, I'd like to tell that this FrontEnd is amazing !
      Thanks a lot Nickolaj to share it with us.
      Next, I have a question regarding the Deployement feature.
      In the documentation, it's written: 
      
      See Troubleshooting section for this documentation if the list of available task sequences (named operating systems in the UI) is empty.
      
      But obviously, there's nothing related to this in the Troubleshooting section.
      And, for sure, I have an empty drop down list.
      My TS name has been set into the config file.
      Any track please ? (need some logs ?)
      Thanks.
      
    • I'll answer myself :p
      
      Page 15 of the document : When ConfigMgr OSD FrontEnd retrieves available task sequence deployments, it does this by looking up if the device is known or unknown and determines what should be presented in the drop down box. Task sequence deployments needs to be configured as #hidden # for media or PXE, like in the example
    • Hehe glad you found that in the docs. It's kind of the point so that you can't circumvent the frontend as an application and get to task sequences without it.
      
      Regards,
      Nickolaj
  • GitHub Source
    2 Posts | Last post March 26, 2018
    • Hello! 
      
      We have been looking into implementing your OSD frontend. There's a few customizations our organization could use, but rather than simply request them I would be interested in assisting with development. Is this something you'd be interested in? 
      
      Thanks!
    • Hi Al,
      
      I'm not going to open-source this for various reasons, one of them being that I've developed some of the features for customers that have agreed to share the outcome, but not the source code. I hope you understand, but please contact me at nickolaj@scconfigmgr.com if you're interested in talking about building a custom version for your organization, I'd be happy to assist.
      
      Regards,
      Nickolaj
  • Authenticating Username Variable
    2 Posts | Last post March 26, 2018
    • Is there a way to pull the username typed into the authentication field, to a variable? I tattoo the registry with some pertinent bits of information, and I would like to be able to throw the username of the person that kicked it off into there as well.
    • Hi, not with the current version, but it sounds like a reasonable request. I'll add it to the list of features.
      
      Regards,
      Nickolaj
  • SMSTSUdaUsers not set
    2 Posts | Last post March 26, 2018
    • Hi.
      
      I´m having issues with the user section of the frontend.
      Using a script to dump all TS variables I can see that the frontend does not set the SMSTSUdaUsers variable. I can set the variable to a static value in the TS and verify that all works in the TS. I have also tried to use the ConfigMgr Webservice 1.5.0 to retrieve the user in PE using a PowerShell-script (using GetCMUser). This also works perfectly. The format of the username is DOMAIN\sAMAccountName using GetCMUser and just the sAMAccountName when using the User section in ConfigMgr OSD FrontEnd.
      
    • Hi Martin,
      
      I'm aware of this issue and will attempt to fix it in the upcoming version.
      
      Regards,
      Nickolaj
  • Computer Not Detected As Supported Model
    2 Posts | Last post March 26, 2018
    • Been working with the new FrontEnd and I am absolutely loving it!  However, I am running into one minor problem.  We deploy a majority of Dell systems on our network and while the majority of systems image no problem, we have a few problem children, the OptiPlex 780 and lower, such as the 760 and 755.  When the FrontEnd checks for a supported computer model during prefilght, it doesn't recognize the any of those models even though it is in the HWModels.txt list on our web server.  It will detect all other models except those.  I have verified it's name in the BIOS, made sure it was spelled correctly and checked permissions just to be safe.  It will even detect an OptiPlex 790 but nothing older than that.  Could this be a bug or am I missing something?  Any help would be appreciated, thanks!
    • Hi,
      
      This probably sounds like a bug. Could you email me at nickolaj@scconfigmgr.com with the model data from BIOS and what you've put into the txt file?
      
      Regards,
      Nickolaj
  • Application Catagories
    2 Posts | Last post March 26, 2018
    • Let me start of by acknowledging this is very nit picky. After implementing the OSD FrontEnd 1.3.0 and the new way that it handles applications. Is there any way to sort the returned category results in alphabetical order? It appears to just grab them in the order that they were categorized in SCCM.
    • Hey, that's being worked on and will be fixed in an upcoming version.
      
      Regards,
      Nickolaj
  • Problems starting DaRT
    1 Posts | Last post February 21, 2018
    • Frontend doesn't launch DaRT successfully. An error comes up saying remote recovery could not initialize terminal services. 
      
      However I can either manually fire off PrestartCommand.ps1 or remoterecovery.exe and have it launch no problem. What am I missing?
  • Change Keyboard Layout for Frontend
    1 Posts | Last post February 21, 2018
    • How to change keyboard layout for Frontend? Especially needed for authentication. Default is English (United states).
  • OSD Frontend not starting
    2 Posts | Last post February 06, 2018
    • Hi,
      
      I'd like to use the tool but it doesn't start. When checking the SMSTS.log, I find the error failed to run 0x800736B1. When starting osdfrontend.exe with the debug option it returns 'The application has failed to start because its side-by-side configuration is incorrect'.
      Do you have any idea what the problem could be?
      Thank you in advance.
      Jurgen
    • I have the same error(i am upgrading from 1.2.0)
  • Dynamic App Tree based on Region
    2 Posts | Last post February 06, 2018
    • 
      First, I would like to say we are looking into your teams OSD front end and web service and things look very promising for us.  We are a global organization where the apps deployed during OSD vary on the country.  Is there a way to use the config.xml for region to populate the AppsCollectionID in the main xml?  Can a variable be used to point to an entry in each region in the config file? 
      
      
      
    • Hi,
      
      Unfortunately not. There's not really any dynamics built between the sections. However in ConfigMgr OSD FrontEnd 1.3.0 you can build your custom Apps section with any folder level and name you want, and associate regional specific apps for each folder. Have a look at the example in the latest documentation.
      
      Regards,
      Nickolaj
61 - 70 of 79 Items