DiskSpeed

Diskspd GUI. Microsoft released diskspd beginning 2015 and called it “a Robust Storage Testing Tool”. I’ve used this program a lot lately, although it is a great storage testing tool a easy interface is missing to start a few tests and a nice report afterwards.

 
 
 
 
 
4.5 Star
(11)
9,361 times
Add to favorites
Servers
6/28/2017
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Query running Diskspd on Azure
    1 Posts | Last post February 15, 2019
    • Hi 
      
      I am wondering why if I run this command on Azure VMs I get rubbish Mib/s
      I have a DS12 V2 with 2 Managed Premium SSD disks (No cache enabled)
      
      C drive is 127GB and E drive is 1024GB - I am getting roughly 5 and 20 Mib/s
      
      diskspd.exe -c10G -t4 -si16K -b16K -d30 -L -o1 -w100 -D -Sh c:\temp\testfile.dat
      
      Was in touch with Microsoft and they said this command is not suitable for Azure VM's
      
      They ran a different Diskspd command and got 127 Mib/s - the issue I have is the command above is what our Software vendor insists on running and refuses to install the software till we sort the Mib/s issue however there does not seem to be a solution for it on MS without going to a silly high spec costing thousands per month which for this app is not worth it.
      
      Any thoughts as to what is in this command string that is causing the low Mib/s
      
      Cheers
      
      Michael
  • How do you run DiskSpeed GUI?
    2 Posts | Last post November 28, 2018
    • I cannot find any information how to start DiskSpeed GUI on my Windows 7.
      I tried with rigth mouse click and within PowerShell als Administrator.
      Here PS says  #requires-command has wrong format, etc...
    • Not sure if it works on Windows 7. Depends on the Powershell version I guess. Try removing line 64, but dont forget to run as administrator
  • Some Bugs to Squash
    3 Posts | Last post November 28, 2018
    • - Using the "-si" switch on line 353 when it should be "-s"
      
      - Line 665 & 667 are reversed. 665 should be "true" and 667 should be "false"
      
      - Incorrect version on Line 2370
      
      - Now that you have an option to "Write Zeros" or "Random" data, you need to have a separate command that creates the test files. The reason why is because diskspd will NOT create a test file with Random Data if the "-w" switch is set to "-w0" which would be the case if someone was doing a READ test. 
      
      So for example, if I wanted to do a READ test on a drive with RANDOM data, using DiskSpeed would yeild incorrect results due to the fact that the "$WriteParameter" would be set to "-w0" if the "Write Zeros" box is unchecked, to which diskspd would interpret as READ ONLY and never WRITE the Random Data to the test file.
      
      The reason I seem to know too much about this is because I actually modified your v0.8.4 script back when you first released it and had already added in the ability to "Write Zeros" as well as a few other little things. So I've already tried and tested all of this long ago. Feel free to contact me if you'd like more info.
    • Hey, Thanks for this feedback and sorry for the late reply. I will look into it. Also, please shoot me a message through my blog.
    • Made the changes. Cant follow you on the -w0 part, I dont see any differences with tests. Contact me to work this out.
  • more save Options
    1 Posts | Last post September 04, 2018
    • The "Export Config" Option doesnt include the "Test File Size". It would be cool, if the option export all Settins. Or better she create a file that is usable as a batch.
      
      I have here some older Windows with a Strange Windows 2012 machine (she doesnt allow me to run DiskSpeed) so it would be nice to have this "batch".
      
      Yesterday i forgot to set the Test file size after i copy the config.csv to another machine and must rerun some tests...
  • Wrong Enable Caching setting
    2 Posts | Last post June 28, 2017
    • Hi Darryl,
      When I tick enable caching setting, then it actually turn the parameter to be disabling cache.
      I tried to run diskspd.exe manually on Azure SSD disk P20 that have IOPS 2300 and I get right result with -Sh parameter.
      Btw, thanks for this great tool.
    • Indeed a little confusing. Updated the GUI: when the box is checked, caching is enabled.
  • Please include option for writing non-zero data
    3 Posts | Last post June 28, 2017
    • Hi there,
      
      Please can you add support for -Z. The default options for diskspd.exe are to write zeros. This can be changed using the -Z option.
      
      Modern SANs can use thin provisioning and do not write zeros to disk, responding without touching the back end disks. This means responses to the tests can provide incorrect information in the current version (0.8.6).
      
      Thanks.
    • Hi Darryl,
      
      I want to second the request of InteraX
      
      Marc
    • Hey Interax and Marc,
      
      I just added the "write zeros", please check it out!
  • Possible to add larger block size?
    4 Posts | Last post October 24, 2016
    • Add 4M and 8M block size please. Very useful for testing backup storage.  
    • Hi, You can type anything you want in the input box :)
    • Ah did not see you had to use block size in K, used to the cmd with M or G, 
    • Hi,
      0.8.4 The ps1 file there are many Chinese garbled, please check, thank you! 
      For example: 777 lines
  • Some suggestions
    1 Posts | Last post June 30, 2016
    • Hi Darryl,
      
      This is indeed an awesome GUI tool! Do you think some basic benchmark features like the following enhancements can be included?
      
      1. Allow to enter series of blocksizes > the test will repeat and outputs append to the result file.
      2. Allow to enter series of Out I/O and loop the test as point 1? 
      
      with these 2 features, this will be so much better and complete. Truly appreciate your contributions.
      
      
  • Error message in 0.8.3 version -- or user error?
    2 Posts | Last post May 18, 2016
    • Hi Darryl,
      
      I'm getting the following error:
      
      PS C:\Users\Administrator\Desktop\DiskSpeed> .\diskspeed
      Invalid size specifier 'H'. Valid ones are: K - KB, M - MB, G - GB, B - block
      Invalid stride size passed to -s
      ERROR: incorrectly provided option: 'sh'
      
      Am I doing something wrong?
      
      Thanks in advance...
    • Hi Eric,
      
      There was a little bug which caused this, fixed.
      Download again :)