Power BI - ConfigMgr Current Branch Dashboard

This dashboard is a new design, has more information and built with current branch in mind... It utilises Microsoft Power BI to connect to your Microsoft Configuration DB and display powerful visuals and data about your environment.

 
 
 
 
 
5 Star
(6)
5,504 times
Add to favorites
System Center
9/10/2018
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Duplicate error
    1 Posts | Last post Tue 11:22 PM
    • Hi.
      I get the following error:
      Collections
      
      Column 'Collection ID' in Table 'Collections' contains a duplicate value 'CAS0000B' and this is not allowed for columns on the one side of a many-to-one relationship or for columns that are used as the primary key of a table.
      
      
      Can you please assist?
      
      Thanks
  • Data source issue
    3 Posts | Last post Sat 12:25 AM
    • I uploaded the report to an onpremise power bi report server an i have a very strange issue, on the web page when i clic manage the report and datasource tab i see two data sources...
      
      One is our SCCM server and the other is pdms01ps1;CM_P01 i cannot remove it..
      
      If i open the report in power bi desktop i see only one SQL data source and it's the good one.
      
      Any idea?
    • No idea why you wouldn't be able to change that on-premise, might be one for Power BI generally as I don't use an on-premise report server. Only suggestion you could try is replace all the parameters in the report to hardcoded ones in case it doesn't like them for some reason.
    • Same problem... it's very weird 
      
  • Load was cancelled by an error
    2 Posts | Last post May 07, 2019
    •  I run the template, it is load, connect to the SCCM DB, but when I try to refresh I get this error "Load was cancelled by an error in loading a previous table."  Cred's and DB name\server are correct.  Any ideas?
    • You'd have to see which table it failed on to give you a better idea. Usually just scrolling down the list of the errors will show you why it failed.
  • DataSource Web Content Error
    4 Posts | Last post April 04, 2019
    • hi, I am getting two errors under the Web folder in Query Editor
      Will this be the cause of it failing to apply query changes after installing the dashboard? 
      (note the tables seem to contain relevant data)
      
      ConfigMgr Technical Blog:
      
      DataSource.Error: Web.Contents failed to get contents from 'https://blogs.technet.microsoft.com/configurationmgr/feed' (410): Gone
      Details:
          DataSourceKind=Web
          DataSourcePath=https://blogs.technet.microsoft.com/configurationmgr/feed
          Url=https://blogs.technet.microsoft.com/configurationmgr/feed
      
      Office 365 Version History:
      
      Expression.Error: The column 'Monthly Channel' of the table wasn't found.
      Details:
          Monthly Channel
    • Getting the same error and have not been able to resolve it.
    • Same here, seems like MS has removed the blog...
      But I found a workaround:
      you can use the webarchive content. Just replace the datasource on the pbix with 
      https://web.archive.org/web/20181123051104/https://blogs.technet.microsoft.com/configurationmgr/feed/
      it works on my dashboard now (and enjoying it on my powerBI server as well)
    • But that means, the content might not be updated as well (which in my case I don't really use this dashboard to follow the blogs).
      
      Alternatively, you can delete the visualization table containing the data (on tab "Admin Center", the top-right end table) and then delete the datasource and query.
  • Load was cancelled
    1 Posts | Last post March 06, 2019
    • Hi,
      I get the following error when applying query changes:
      
      
      Antimalware Health Status
      Microsoft SQL: The SELECT permission was denied on the object 'vSMS_G_System_AntimalwareHealthStatus' database 'mysccmdb', schema 'dbo'. 
      
      
      We don't use Endpoint. Could you guide me? 
      Thanks!
  • Load was Cancelled
    2 Posts | Last post February 27, 2019
    • Hi Raf - I am trying to use this awesome Dashboard of yours, but I keep getting the error "Load was cancelled by an error in loading a previous table."  I got it to connect once, but now it seems to not want to connect.  Cred's and DB name\server are correct.  Any ideas?
    • Seems the TPM classe is incomplete, follow the steps here : 
      https://www.systemcenterdudes.com/win32_tpm-class-in-hardware-inventory-is-missing-data-by-default-in-configuration-manager-2012/
      
  • Dashboard data refresh Date/Time
    1 Posts | Last post February 23, 2019
    • Hi Raf,
      
      Congrats on the dashboard. Impressive and very useful.
      
      A suggestion for a future release would be to include the date/time of the data import on top of each dashboard. I plan to use Power BI web to to publish the reports so having the date reflected would ideal.
      
      Many thanks
  • Improvement Suggestions
    2 Posts | Last post February 04, 2019
    • Hi Raf,
      
      I've been using your dashboard for a while now and finally decided to dig into it a little deeper than the usual person. How could I go about suggesting some improvements for the dashboard going forward? For example, I have adjusted my dashboard so that it gives a better reflection of the percentage of my estate that is fully patched or not. Would love to help you out with this if you want the input. :D
    • Hi Marcus, 
      
      Always open to input :), if you want to reach out contact me on twitter @raf_delgado and we can go from there. 
      
      Cheers, 
      Raf
  • Also getting errors when loading
    5 Posts | Last post February 04, 2019
    • Hi Raf, I'm getting the following error on Devices:
      
      Comlumn 'ResourceID' in Table 'Devices' contains a duplicate value '16810111' and this is not allowed for columns on the one side of a many-to-one replationship or for columns that are used as the primary key of a table.
      
      Can you provide any assistance?  Thanks!
    • Hi djenkins, 
      
      Ping me an email at bibeta at poweronplatforms.com and we can discuss to help you further. 
      
      Thanks,
      
      Raf
    • I am getting the same as djenkins except the value is 16792893
      
      Thanks
      Herb
    • I am getting the same error but the resource ID duplicate is 16797494.
      
      Thanks in advance for your help...
      
      Anthony
    • Hi guys, 
      
      Run the "How to test for duplicates" function in the query editor, it will show you wants coming back with a duplicate name. It's usually some random hardware device being picked up or old device still in the system. 
      
      https://thedevopshub.com/power-bi-configmgr-current-branch-dashboard-1806-update/
      
      Notes for how to check on the site above. 
      
      Thanks,
      Raf
  • SQL permissions
    3 Posts | Last post February 04, 2019
    • Hi Raf
      
      Looking forward to using this dash, but could you help with SQL permissions? 
      I've created an AD user account and granted db_datareader access to the CM DB, but when I run the dash queries I get an error "Either a required impersonation level was not provided, or the provided impersonation level is invalid. (Exception from HRESULT: 0x80070542)"
      If I look at the queries and the tables, I can see the data, but the queries fail.
      What permission does the account need for the queries to run?
      
      Thanks
      
      Matt
    • I am having the same issue:
      DataSource.Error: An error happened while reading data from the provider: 'Could not load file or assembly 'System.EnterpriseServices, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. Either a required impersonation level was not provided, or the provided impersonation level is invalid. (Exception from HRESULT: 0x80070542)'
      I am on CB 1810
    • Hi Matt, 
      
      The DB fragmentation needs the dbo schema rights to the master system database. If you've set this, then try running BI desktop under elevated admin.
      
      Thanks,
      Raf
1 - 10 of 21 Items