Hyper-V Backup Utility

Flexible Hyper-V Backup Utility It's designed to be run on a Hyper-V host. A leading feature is that the utility can be used to backup VMs to a device which the Hyper-V host does not have permission to run an regular export.

 
 
 
 
 
5 Star
(5)
5,512 times
Add to favorites
2/28/2020
E-mail Twitter del.icio.us Digg Facebook
  • Performance and Network optimizations
    4 Posts | Last post February 24, 2020
    • Hi,
      Thanks a lot for this beautiful script!
      I only had 2 issues with the script.
      The io.compression.zipfile function has been slowing down the backup process in such a way that is was almost unusable. I changed it to use 7zip and everything works 10 times faster.
      Another performance problem was that the export goes into the same directory as the compressed VM goes. This has been slowing down the backup process a lot as well.
      I changed your script to export the vm to a local directory and only store the created compressed file on the network storage. That gave another greate Performance increase.
      
      Could u plz add those features in future versions of your script?
      Best Regards,
      Jim
    • Hi could you please share your code changes?  I too would like to get these added but can't wait for the author to update it.
    • Hi there,
      
      I only just saw this comment as notifications seem to not be working for me.
      
      I'll consider added it in a future update - should be soon!
      
      -Mike
    • HI team could you please share the steps which you have performed to improve the performance.
      
      Best Regards,
      ZB
  • backup is not working
    2 Posts | Last post February 07, 2020
    • Hi mike,
      
      I have added all the parameters in the script but when i run it stops in the Backup: and there is no process after that, Please help me i am attaching my screenshot what i have configured what output showing in powershell…Please let me know the solution where i am wrong?
      
      Screenshot - https://i.imgur.com/lUwIY17l.png
    • Hi ajay - I've answered your comment on the blog.
      
      I only just saw this comment as notifications seem to not be working for me.
      
      -Mike
  • Script with problem?
    1 Posts | Last post August 09, 2019
    • This scripts is very powerfull... Very good...
      
      When I run the script, the following problem occurs:
      
      07/08/2019 16:56:49 Starting VM: SVEXSA006
      Where-Object : A positional parameter cannot be found that accepts argument 'Removing'.
      At C:\Tools\Scripts\BKP-VMS-HYPER-V\Hyper-V-Backup.ps1:392 char:88
      + ... Directory | Where-Object CreationTime â?"lt (Get-Date).AddDays(-$Hist ...
      +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          + CategoryInfo          : InvalidArgument: (:) [Where-Object], ParameterBindingException
          + FullyQualifiedErrorId : PositionalParameterNotFound,Microsoft.PowerShell.Commands.WhereObjectCommand
      
      Any ideia?? 
      
      My Powershell version is 5.0
      
      Thx 
  • Its working great, But why its creating a Checkpoint for a VM ??
    2 Posts | Last post August 09, 2019
    • The script is working great, however its creating a checkpoint for a VM which taking a backup and its not deleting it after completion. 
      Can any one please suggest 
    • Anyhthing about this? I have the same problem...
      Thx
      
      Very good script... Congratulations..
  • Script work in cluster
    2 Posts | Last post July 27, 2019
    • Hello! Wonderful script! But when you start exporting a virtual machine in a cluster Windows 2012R2, when the owner is a different host, the message appears: Export-VM: Invalid parameter. Hyper-V could not find a virtual machine named win7_test.
      And the letter comes about a successful export.
    • Hi there,
      
      Unfortunately I didn't write this script with clusters in mind originally. When VMs change hosts, it's not smart enough to find the VM and export it. The script "supports" clusters in that when run on a Hyper-V host which is part of a cluster, it works. When the script is run on all Hyper-V hosts in a cluster and configured to export all VMs, it should successfully backup all the VMs.
      
      -Mike
  • what is the Syntax of a txt file
    2 Posts | Last post May 29, 2019
    • Hello,
      Could you please let know what is the syntax of a text file ?
      Is it the UNC path of the virtual machine folder or only the virtual machine name ?
    • Please ignore my above question 
  • Varible
    3 Posts | Last post February 21, 2019
    • Hi,
      
      I have customized the script and in works 100% except for one small issue.
      It requires manual input for the backup variable for some reason, everything else works fine except for the first variable in the list.
      
      Please help
    • Hi, sorry for the delay, only just saw this.
      
      What customisation's have you made? I use it weekly, as it is here, completely automated - no user input.
      
      Thanks,
      Mike
    • Hi Mike,
      
      I have runned the script without any customization, but i got the same Issue like Jdhuyzer. It requires manual input for the backup variable.Everything else works fine after i put the path for the backup (D:\VM_BACKUP). How can i put the path in the scrip for automatical run? thank you .
  • iSCSI connection to circumvent NAS access issues / NoPerm
    1 Posts | Last post December 26, 2018
    • Hi Mike,
      
      Thanks for the great script. I really do like my backups as simple as possible.
      
      I ended up creating an iSCSI connection to our Synology NAS. This way no SMB style network access is required by the VM Host and therefor an online backup can be run (without the NoPerm  switch). 
      
      
  • Fails to backup Ubuntu server 18.04 VM
    3 Posts | Last post December 06, 2018
    • The script works perfectly for me with my Windows server VM's (both 2008 R2 and 2016) on a 2012 host, however it fails to work for my Ubuntu server 18.04 VM. What can be the issue here?
    • Hi Siverstrale,
      
      The script interfaces with Hyper-V and not the guest OS, so I'm afraid I don't know what the issue could be.
      
      -Mike
    • I have the same problem with an other Debian distribution. The script works well with the Windows-VM, but there is no backup of the Linux-VM. The directory is created, but it is empty. It doesn't matter if i run the script with or without Perms.
      More output from the logs would be good for troubleshooting.
  • W10 64bit ita pro 1803 "ERROR: There was a problem copying the VHDs for"
    1 Posts | Last post November 22, 2018
    • W10 64bit ita pro 1803 17134.407 (production)
      
      i get this error:
      
      ERROR: There was a problem copying the VHDs for myserver
      
      of course there is enough disk space, i suspect some permission issue
      
      any help?
      any hint?
      
      thanks
      regards
      
      massimo s.
1 - 10 of 20 Items