SCCM Extensions for driver management and server side code execution

Key features are dynamic driver handling based on hardware models and secure server-side code execution. It’s also possible to assign programs and applications for dynamic installation during deployment. A custom TS Action for running server-side code is added.

 
 
 
 
 
4.8 Star
(5)
1,062 times
Add to favorites
System Center
8/2/2018
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Source Code
    1 Posts | Last post June 08, 2019
    • Is it possible to obtain the source code?
  • CM 1810 Problems
    1 Posts | Last post February 25, 2019
    • Hi,
      After upgrade to CM version 1810 we get some errors with this solution.
      First the models in the dropdown list in the console is no longer in alphabetical order. This is a nuisance we can work around but the next error is worse. 
      If i look in event log I can see this message:
      GetDriverPackageForComputer Called with parameters Vendor: [Dell Inc.] Model: [Latitude E5470] OsId: [XXXXXXXX]
      But on the clients smsts.log I get this message: 
      [WARNING] DriverInstallerClient 2019-02-25 10:39:22 Web service didn't return any driver information.
      It worked fine in 1806. Is it just me that has forgott something or does anyone else have problems in 1810?
      
  • Maximum character limit in custom script
    4 Posts | Last post February 18, 2019
    • Hi,
      
      It seems there is a maximum character limit of 218 in the run custom script task. Is that a technical limitation or a bug?
      
      If there are more characters - it will always fail, with something like this:
      Failed to Create Job [{"Cmd":"Custom","Name":"","Arg":"powershell.exe -ExecutionPolicy Bypass -file Test-Mail.ps1 -ComputerName 'TestComputer1' -Message 'tTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestT'"} Error: Unexpected end when deserializing array. Path '[0]', line 1, position 254.
      
      There are exactly 254 characters from [ to }, I guess the job can't contain more than 254 characters and it's failing because the closing ] is truncated.
    • Seems like you have found a limitation in the actual status message that is used for transferring the command. Not much (at least for the moment) I can do about it, will however file this and look for a solution for the next revision. Thanks for reporting it, is there a way you can truncate the message?
    • Yes, I used a cmd file as a workaround to truncate it:
      powershell.exe -ExecutionPolicy Bypass -File %1 %2 %3 %4 %5 %6
      
      Then I just call it:
      ps.cmd Send-Mail.ps1 Param1 Param2 Param3 Param4 Param5, etc.
    • I don't think it's the status message limit that is hit but a InsertionString (msgis01) limit. 
      My best guess is that the extension is using only one for the command.
      Tried it and combining multiple strings should solve it. :)
      (The entire command I used is longer but easier make sense of this way)
      
      InsertionString1
      Something went wrong while posting the message. Windows reported the error: The string is too long
      Result:
      Something went wrong while posting the message. Windows reporte
      
      Splitting it and then combining InsertionString2 and 3 
      Result:
      Something went wrong while posting the message. Windows reported the error: The string is too long.
  • CM 1810 Console Extension crashing
    2 Posts | Last post February 13, 2019
    • Hi,
      
       since 1810 update it looks like the console extension is crashing the console every time i click on it
      anyone else having this issue?
    • having this issue too. 
      After uninstall and install the extensions they not even show up in console :(
      can anyone help?
  • Issue with TS working
    2 Posts | Last post August 02, 2018
    • I have installed all components but scripts just aren't running.  The Windows service is running, the config file is pointing to the correct location but still the scripts don't run.  I even tried running powershell.exe -command (get-process | out-file "C:\test\test.txt") but although the TS completes successfully, there is no file created.  Instructions are minimal and I have followed them, what can I be missing?
    • Nevermind, sorted it
  • "Set Computer Description in AD" add the Date
    2 Posts | Last post July 26, 2018
    • Hi,
      
      it is possible to add in "Set Computer Description in AD" the current date? 
      
      Example: "Installed at 26.07.2018 with SCCM"
    • Perhaps you could just create your own variable.
      
      Something like this as a PowerShell script just before the server command:
      
      $tsenv = New-Object -COMObject Microsoft.SMS.TSEnvironment
      $tsenv.Value("DeploymentTime") = (Get-Date -Format "dd.MM.yyyy")
      
      And this in the Server command:
      
      Installed at %DeploymentTime% with SCCM
      
      PS. Will not work in PE, must run in full OS.
  • Last Version not working
    2 Posts | Last post July 24, 2018
    • After i install the last Version Update 7/21/2018 the DriveInstaller not working anymore.
      
      Error in smsts.log: "Failed to run the action: DriverInstallerClient. The application has failed to start because its side-by-side configuration is incorrects."
    • Please ignore thie error report, i have not changed the config.
  • Fallback if no driver package is assigned
    3 Posts | Last post July 21, 2018
    • It would be great if a computer model has not been assigned a driver package, then that all drivers are searched if suitable drivers are available. Can you please add this feature? Or as an alternative that Onevine sets a tasksequence variable and then you can start the Tasksqeunz general driver search if necessary.
    • Yes, please add this feature!
    • Check change log.
  • Error with Special Characters in Server Side Commands
    13 Posts | Last post July 20, 2018
    • We are trying to set an AD Description on Computer Objects but getting an Error when passing though a Variable with a Backshlash.
      Whether it is with the Build in Task "Set Computer Description in AD" or with a Custom Script.
      
      Failed to Create Job [{"Cmd":"Custom","Name":"","Arg":"Powershell.exe -ExecutionPolicy Bypass Set-ADComputerDescription.ps1 -OSDDomainName 'KVS.kuma.intra' -OSDComputerName 'KVSDOTEST01' -SMSTSUdaUsers 'KVS\dchrobok'"}] Error: Bad JSON escape sequence: \d. Path '[0].Arg', line 1, position 187.
      
      The Backslash in SMSTSUdaUsers seems to be the Problem.
      Can you help?
      
      BTW: Nice Tool. Really helpfull for many Situations.
    • Please, download and try the latest version (2018-07-17). Console extensions and windows service msi's can be installed "on top" of older versions. Webservice has not been updated, leave as is....
    • Hello Johan, thanks for the fast response.
      Unfortunately the fix only works partially for us.
      The Error has disappeared and it now seems to do something but the Script isn´t executed at all.
      
      Attempting to run Custom Command exe: Powershell.exe arguments: -ExecutionPolicy Bypass Set-ADComputerDescription.ps1 -OSDDomainName "KVS.kuma.intra" -OSDComputerName "KVSDOTEST01" -SMSTSUdaUsers "KVS\dchrobok"
      
      It also doesn´t create a Log File in the "ScriptLogs" Directory.
      Manually runned with Powershell it creates the Log File and also execute the Changes.
      
    • How about the builtin action, I tested that 😉
    • I am unable to use that because the Target-Computer Domain is different to the SCCM-Server Domain.
      
      "No AD result for: KVSDOTEST01"
      
      Sorry :)
    • Attempting to run Custom Command exe: Powershell.exe arguments: -ExecutionPolicy Bypass Set-ADComputerDescription.ps1 -OSDDomainName "KVS.kuma.intra" -OSDComputerName "KVSDOTEST01" -SMSTSUdaUsers "KVS\dchrobok
      
      It isn't as simple as this (-File missing):
      
      arguments: -ExecutionPolicy Bypass -File Set-ADComputerDescription.ps1 -OSDDomainName "KVS.kuma.intra" -OSDComputerName "KVSDOTEST01" -SMSTSUdaUsers "KVS\dchrobok
      
    • hmmmm also with the -File Argument it does nothing :(
      I created a Test Powershell without any Arguments which only writes some Lines into a txt File but when executed from a TaskSequence with the "Run custom script" it does nothing.
      
      Although it Logs the attempt: Attempting to run Custom Command exe: Powershell.exe arguments: -ExecutionPolicy Bypass Test.ps1
      
      Can I debug this any further?
      Sorry for the inconvenience.
    • The "-File" switch is still missing here, perhaps you didn't wait long enough for the policy to refresh:
      
      Although it Logs the attempt: Attempting to run Custom Command exe: Powershell.exe arguments: -ExecutionPolicy Bypass Test.ps1
    • Well I tested the -File Parameter with the Script above (Set-ADComputerDescription.ps1)
      But I get the same Results with the Test.ps1 if I Set the -File Parameter :)
      Nothing happens.
      
      Hmmm I swear it worked with the old/non-fixed Version. Although I was getting the "Error: Bad JSON escape sequence" with a Backslash in the Parameter but if I omitted the Backslash for testing purposes it executed the Script.
      
      Can it be possible?
      Maybe I should try to reinstall the whole Suite?
    • OK. I found Cause of the Problem :)
      
      The OnevinnTSCommandExecutor.msi doesn´t Set the correct "ScriptFolder" key under OnevinnTSCommandExecutor.exe.config.
      
      Tried it 3 Times. I set it to "D:\Onevinn\TSScripts" in the Installer but in the File it is set to: <add key="ScriptFolder" value="c:\TSScripts"/>
      
      Because this Folder doesn´t exist on my Server it was not able to execute any Scripts.
      I changed it to the correct Folder, restarted the Service, and now it´s working fine.
      
      Many thanks for your Help :)
    • And indeed thanks to you; two bugs down, json and the path to scripts :)
    • hmmm maybe I was too fast with my last post.
      These 2 Bugs are still there. But in another form ;(
      
      First the Setup/ScriptsFolder Bug:
      If I set the Scripts Folder to "D:\Onevinn" in the Setup it creates a TSScripts Folder under this Path. But in the Config File it leaves it as "D:\Onevinn". The "\TSScripts\" is missing then. If set to "D:\Onevinn\TSScripts\" in the Setup it places the TSScripts Folder under the configured one but also ommitted the Second "\TSScripts\" in the Config.
      
      Second the Special Character Bug:
      It now works if I Test it with a "Static" Variable declaration. Without a dynamic SCCM Variable.
      
      Like if I set the TS Step for testing purposes to: 
      Powershell.exe -ExecutionPolicy Bypass -File Set-ADComputerDescription.ps1 -OSDDomainName "KVS.kuma.intra" -OSDComputerName "KVSDOTEST01" -SMSTSUdaUsers "KVS\dchrobok"
      
      But if there is a Variable with a Special Character in there it still brings the "Error: Bad JSON escape sequence".
      Powershell.exe -ExecutionPolicy Bypass -File Set-ADComputerDescription.ps1 -OSDDomainName "%OSDDomainName%" -OSDComputerName "%OSDComputerName%" -SMSTSUdaUsers "%SMSTSUdaUsers%"
      
      Sorry for the Confusion :)
    • #1:
      That is expected, it doesn’t automatically add an extra level “TSScripts”. If you set the path to for example “S:\MyCompany\MyScripts” during installation “MyScripts” becomes your “TSScripts” folder.
      
      #2:
      Tricky but should be solved now. Tested with a combination; one “static” argument and one “dynamic” from TS Variable – both worked.
      
  • Use Server-side excecution model in place of Web service?
    1 Posts | Last post July 12, 2018
    • Would you consider integrating the server-side commands with the driverinstallclient?  It would be great to use these two items together for driver management without requiring the web services :)
1 - 10 of 20 Items