SendEmail for Service Request Fulfillment

The purpose of the solution is to allow the Service Desk console user to send email notifications to other users regarding a particular Service Request. The solution is a dialect of the SendEmail solution which is a part of the Exchange Connector (created by Travis Wright).

 
 
 
 
 
4.9 Star
(13)
2,077 times
Add to favorites
System Center
10/28/2012
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Is there any place to get the source code
    1 Posts | Last post January 09, 2017
    • Hello,
      
      is there any place to get the source code for the modified assembly. I would like to try upgrading it to support SCSM 2016. Unless there is a version for 2016 already.
      
      Thank you
      Sascha
  • Was there an update for sending an additional email?
    1 Posts | Last post April 08, 2014
    • Hello
      
      Thanks for this very useful tool.
      
      You mentioned that you'd be updating the documentation with regards to how to get an email to be sent if the Send Email task was run again (Raphael Blanchet below).
      Did this ever get implemented please? I'm fairly new to Service Manager and I'd really like to know exactly how to get this working so that, if someone wants to send an additional email, they can, without changing the text in the Message box of the Service Request form.
      
      Thanks
      
      Paul
  • Multiple 'Record Opened' action log entries
    1 Posts | Last post December 31, 2013
    • Hi Patrik
      
      This solution works a treat!  I have however found an issue.  It looks as though this MPB generates a second 'Record Opened' action log entry when a Service Request is created.  i.e. there are two 'Record Opened' entries created rather than one.  Any ideas why this might be?
      
      Cheers
      
      Shaun
  • CodePlex
    1 Posts | Last post November 14, 2013
    • Hi Patrik - 
      Do you want to contribute this code to the SCSMSendEmail.CodePlex.com project now that I have put it up there?  If so, let me know and I'll add you as a contributor on the project so you can upload the modified source.
  • Can I adapt this to work in Activities?
    1 Posts | Last post June 21, 2013
    • Is it difficult to do this for Activities?  I think I can change the XML with the custom MP that I am using for workflow, etc. but can I alter the SendEmail MP that you have posted here to work with Activities?
  • PropertyName Error
    2 Posts | Last post May 08, 2013
    • Hi Patrick,
      
      Thanks for this great MP. 
      But i'm unable to send emails. I've just following the manual but when i send an email from a service request i recieve a PropertyName error with the following output:
      ___________________________________________________________________________
      Date: 5/8/2013 10:17:04 AM
      Application: System Center Service Manager
      Application Version: 7.5.2905.0
      Severity: Error
      Message: propertyName
      
      System.ArgumentException: propertyName
         at Microsoft.EnterpriseManagement.UI.SdkDataAccess.ConsoleTaskHandler.DoTask(IList`1 navigationNodes, NavigationModelNodeTask task, List`1 parameterList)
         at Microsoft.EnterpriseManagement.UI.SdkDataAccess.ConsoleTaskHandler.DoTask(IList`1 navigationNodes, NavigationModelNodeTask task)
         at Microsoft.EnterpriseManagement.ConsoleFramework.WindowJobRecord.ExecuteBackgroundJob(Object sender, ConsoleJobEventArgs eventargs)
         at Microsoft.EnterpriseManagement.ServiceManager.UI.Console.ConsoleJobExceptionHandler.ExecuteJob(IComponent component, EventHandler`1 job, Object sender, ConsoleJobEventArgs args)
      _________________________________________________________________________
      
      Know you what i did wrong?
      
      Kind regards,
      Dennis
    • very strange, but after a restart?! It will works fine.
      
      Thnx!
  • Can you select a different template?
    2 Posts | Last post January 17, 2013
    • Hello,  This is related to my other post.  It appears that when an end-user responds to an email message and the Service Request appends the message, the default Service Request Template is applied.  This causes the two default activities to be added to the Request which I do not want.  Is there a way to modify the default template or have your solution pick a different template?
      
      Thanks!!
    • Hi Don,
      
      As I wrote in your other question. This has to do with your Exchange Connector. You can specify which template that should be applied "When Service Requests are updated" on the Exchange Connector. So choose a template without activities. :)
  • Service Request Question
    2 Posts | Last post January 17, 2013
    • Hello,
      
      It appears that when an end-user replies to an email message when the message comes back, it appends it to the correct Service Request.  That's very cool but I have an odd issue.  It appears that the default Service Request template is then applied to the ticket and inserts the default activities which I do not want.  Have you heard of this?
      
      Thanks!!
    • Hi Don,
      
      This has to do with your Exchange Connector. You can specify which template that should be applied "When Service Requests are updated" on the Exchange Connector. So choose a template without activities... :)
  • Using SendEmail more than once per Service Request
    2 Posts | Last post January 17, 2013
    • Hi Patrik, 
      
      Thanks for the SendEmail for Service Request Fulfillment solution, I got this working in Dev for a customer. :)
      
      One scenario I have noticed is when the Analyst tries to use SendEmail more than once for the same Service Request. For Example:
      1 - Analyst clicks Send Email the 1st time, the message is added to the log and the Affected user receives the email requesting more info.
      
      2 - Analyst clicks Send Email a 2nd time for the same Service Request (let's say he/she wants more info that requested in 1st message, the workflow doesn't run a 2nd time, so the Affected User does not receive a 2nd email requesting (even) more info. 
      
      Should the 2nd notification work? Does this have to do with the suggested criteria for the Workflow configuration (i.e. change from message equals empty, to Change to message is not empty? 
      
      Thanks. 
      
      Raphael
      
    • Hi Raphael,
      
      You're right. When nothing is changed no workflow will be triggered. One way to solve this would be to apply a template in the same workflow that sends the email notification. The template should reset MessageType and Message, so these would have to be changed next time you want to send an email. Also, the criteria for the workflow would propb. also need to be modified to not trigger again when the template "resets" the MessageType and Message. I'll look into this an update the documentation. 
  • Not accepting the edited MP
    2 Posts | Last post December 18, 2012
    • I've made the edits as shown in the guide (at the end)... but I am getting the following error and I can't find much on it.
      
      The management pack import failed. 
      Errors (1):
      The configuration specified for Module DS is not valid.
      : Cannot find ManagementPackElement [Type=ManagementPackClass, ID=ServiceRequestSendEmailExtension] in management pack ManagementPack:[Name=SendEmail.ServiceRequestFulfillment, KeyToken=37b4f4e0465f2747, Version=1.0.0.13].
      
      Thoughts?
      
      Thanks,
      Terry
    • Hi,
      
      Drop me an email with your MP and I'll take a look.
      patrik(at)litware(dot)se
1 - 10 of 12 Items