Exchange 2010 SP1 (and later) ExFolders

This new tool is really just a port of PFDAVAdmin to Exchange 2010. We changed the name to ExFolders because it no longer relies on DAV, and it's not just for public folders (even PFDAVAdmin, in its public release, was not just for public folders). The name just didn't make s

 
 
 
 
 
4.5 Star
(96)
155,119 times
Add to favorites
Exchange
3/17/2016
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • how do I fix: Object reference not set to an instance of an object
    1 Posts | Last post April 18, 2017
    • I’m trying to export folder properties in ExFolders (V2.8) and getting error:
      “Object reference not set to an instance of an object”. 
      I am having this issue on my 2 primary public folder servers. 
      how do I fix this error?
  • Error: Object reference not set to an instance of an object
    1 Posts | Last post March 13, 2017
    • I’m trying to export folder properties in ExFolders (V2.8) and getting error:
      “Object reference not set to an instance of an object”. 
      Running ExFolders as Admin, getting this on all PF Servers and for any “new” or “old” Public Folders. Does anybody have an idea how to get around this error ?
      
  • ExFoldes and Permissions
    3 Posts | Last post September 26, 2016
    • Dear all
      
      I need to solve this issue: https://sites.utexas.edu/glenmark/2012/06/14/troubleshooting-doc_too_huge-errors-in-exchange-content-indexing/.
      So ExFolders is the tool. But it always exports the folder details only for mailboxes for which I do have full access.
      But to find the ptagPID: 0×67480014 of the mailbox and the folder which causes this error I would need to do a bulk export of all mailboxes from one DB. To bring this to work, this would mean, that I previous need to grant me full access to all! the mailboxes on this DB.
      
      But this is not feasible, well it is not completely, but it complicates this very much, because after wards I would need to remove all the permissions from all the mailboxes again.
      
      Is there an other way without granting full access to all mailboxes, to find the mailbox, the folder and in the end the item which causes this issue?
      
      Kind regards
      
      Matthias
      
    • Use the following command to grant access to all mailboxes:
      
      Get-Mailbox | Add-MailboxPermission -User <UserorGroupIdentity> -AccessRights Fullaccess -InheritanceType all
      
      
      When done just change Add to Remove:
      Remove-MailboxPermission -Identity "Test" -User Administrator -AccessRights Fullaccess -InheritanceType all
    • Thanks Franky_M.   That command got my EXFolders.exe program to finally show the mailboxes without a permission error.  Now, back to troubleshooting (finally).
  • ptagMID : 0x674A0014
    1 Posts | Last post April 05, 2016
    • I've having an issue with locating the actual message using the ptagMID property. I followed the directions found on Google about adding ptagMID : 0x674A0014 to the property list which I did but when I do the export, I get this:
      
      Folder Path	ptagMID : 0x674A0014
      
      Mailboxes\user@ourdomain.org\Top of Information Store\Sent Items
      
      PropertyError: NotFound
  • Will Exfolders import a SETREPLICAS list to remove replicas from Exchange 2007?
    4 Posts | Last post February 03, 2016
    • We are having issues with Exfolders removing replicas from the origination server. We load balanced our public folder infrastructure with pfdavadmin by importing a replica list to add and import a replica list to remove.
      
      Example:
      
      IMPORT INTO PFDAXADMIN TO ADD NEW REPLICAS TO TARGET REPLICATION PARTNER
      
      SETREPLICAS	Departmental Exchange Folders\Accounts\Billing	ADD	SERVERTOMOVEREPLICATONAME	NO
      
      
      IMPORT INTO PFDAVADMIN TO REMOVE ROGINAL REPLICAS FROM ORIGINATION SERVER
      
      SETREPLICAS	Departmental Exchange Folders\Accounts\Billing	DELETE	ORIGINATIONSERVERNAMETODELETEREPLICAFROM	NO
      
      This method still works going from Excahnge 2007 to Excahnge 2010
      
      Exfolders will import and create the replicas but it will not remove the delete import.
      
      It just ignores the delete request (delteing the replica from 2007)
    • Still looking for an answer to this issue. Now we are fully migrated to 2010 and the Exfolders import works great ay creating replicas on another server. However it will not remove them. We importing a txt file using the following format:
      
      SETREPLICAS	Departmental Exchange Folders\....	ADD	2nd2010PFServer	NO
      
      and trying to remove the old replica by importing the following:
      
      SETREPLICAS	Departmental Exchange Folders\....	DELETE	1st2010PFServer	NO
      
      This is a single folder that we used as a test. 
      
      Running the following Powershell to compare mail items before we remove the replica.
      
      Get-publicfolderstatistics -server 2nd2010PFServer  -identity "\Departmental Exchange Folders\......" | FT Name, ItemCount
      
      Name                                                                  ItemCount
      ----                                                                  ---------
      Test                                                                        1284
      
                                                                             1284
      Get-publicfolderstatistics -server 1st2010PFServer  -identity "\Departmental Exchange Folders\......" | FT Name, ItemCount
      
      Name                                                                  ItemCount
      ----                                                                  ---------
      Test                                                                        1284
      
      On 2007 this process worked flawlessly with PFDAVADMIN 2.8
    • SOLVED!!!!
      
      It was the version of Exfolders. Only version 14.17.0371 allows the importing of a list of folders in a txt file to remove replicas.
      
      These versions do not allow you to DELETE the replicas but do allow you to create the replicas:
      
      Exfolders VERSION 14.17.0458.00 – BAD 5/21/2014 (Latest version on TechNet- as 1/29/2016)
      Exfolders VERSION 14.17.0328.00 – BAD 10/2/2013
      
    • Microsoft updated Exfolders. 2/3/2016 
  • Can this tool add a folder class to a folder that doesn't have one?
    1 Posts | Last post November 12, 2015
    • I have several mailboxes that seem to have folders that don't have a folder class...i.e IPf.note assigned to it for some reason.  I have 1,400 mailboxes that I may need to do this to. Is this possible with this tool?
  • ExFolders without mailbox server
    1 Posts | Last post October 02, 2015
    • Will ExFolders alway require a mailbox server?  This creates issues for me.
      
      I want our SD to use ExFolders I don't want them to be logging into a mailbox server. I've built a tools server that also has the mailbox role but this causes issues with the database and store service.  Would be nice to be able to run exfolders on a tools machine, allow help desk role to access it.
  • How to replace Public Folder Permissions Recursively?
    1 Posts | Last post August 05, 2015
    • Getting
      "Updating permissions..."
      "Replace permissions failed with exception: SecurityPrincipal must at least have a valid index string."
      
      How to fix or what could I be doing wrong? 
  • domain-level rights, or not
    1 Posts | Last post July 29, 2015
    • I need a method to assign delegate rights that will not be domain level rights.  We do not want our delegates to see private messages in OWA, which is the problem with assigning domain level rights.  But I do want an easy way to assign rights to all folders in their boss's mailbox so ExFolders looks like the right tool, except for this one issue.  Please clarify whether ExFolders assigns domain level rights, or whether it acts more like the Outlook method of providing delegate access.  Thanks.
  • SCOM Support?
    1 Posts | Last post July 12, 2015
    • Will this work with MPs of scom?
1 - 10 of 54 Items