OneDriveMapper automatically map your OneDrive for Business upon login

This script maps your Onedrive / Sharepoint / Teams document libraries to driveletters (or shortcuts). It can be used in any environment (VDI, RemoteApp, w10 etc).

 
 
 
 
 
4.6 Star
(116)
75,562 times
Add to favorites
Office 365
2/3/2019
E-mail Twitter del.icio.us Digg Facebook
  • Issues on published apps in Citrix
    2 Posts | Last post March 04, 2020
    • Hi Jos,
      
      This script is pretty awesome but I ran into some issues in our Citrix environment when users launch published applications.  We previously used AppSense to run the app in pre-desktop state but we are moving away from AppSense and when I run the script as a login script, immediate task schedule or in the published application launch script it seems to map the drive and make a connection to Onedrive but no files are visable only folders.  If I launch it as published desktop everything works fine.  Just curious if you had any insight, thanks!
    • So I got it working by upgrading to the latest version of the script :)  I noticed the version we were running was .17 and the new servers we are using are 2019.
  • Map a Shared Library
    1 Posts | Last post February 25, 2020
    • Hi Jos, thank you very much for the script.
      I have a doubt, is it possible to map a "Shared library"?
      
      https://prnt.sc/r7g9qw
  • Make sure you're using the latest version!
    2 Posts | Last post February 18, 2020
    • This is not a question, it's more of a heads up to anyone else going crazy trying to get this thing working and coming here to troubleshoot. The version on this page (at least as of now) is 3.19 - the current version is 3.21. I was up and running within about 10 minutes after realizing this and using the current version. Hopefully this saves somebody else the few hours I lost scratching my head and getting nowhere!
    • Good heads up ;) I can't update the page here anymore either, I think technet is being retired or having other issues. Always check the source (git) if you want the latest :)
  • Sorry, we are having some temporary server issues
    1 Posts | Last post February 01, 2020
    • Hello,
      
      When we map a new SharePoint library to a user, they receive the following error message when they click to open it via Office 2013:
      "Sorry, we are having some temporary server issues"
      
      They do not get this error message when opening the library via File Explorer.
      
      Office seems to cache some old login details from previous mapped libraries. My only workarround atm is resetting the users profile... 
      
      Any good ideas? :)
  • Failed to find the correct controls
    1 Posts | Last post December 31, 2019
    • Hello,
      
      I tried running the script many times with no success.  I tried tweaking/troubleshooting it but I keep getting the following:
      
      ERROR | Failed to find the correct controls at https://login.microsoftonline.com/login.srf?msafed=0 to log in by script, check your browser and proxy settings or check for an update of this script or switch to Native mode. The element i0116 was not found (2) or had no tagName
      ERROR | IE auth login mode failed, aborting script
      
      Any ideas, thoughts, and/or input would be greatly appreciated!!!
      
      Thanks,
  • I am getting this error message and failed after numerous attempts....
    3 Posts | Last post December 31, 2019
    • WARNING | Failed to force sign in persistence
      INFO | Retrieved user password from cache C:\Users\*****\AppData\Roaming\OneDriveMapper.tmp
      ERROR | Failed to find the correct controls at https://login.microsoftonline.com/login.srf?msafed=0 to log in by script,
      check your browser and proxy settings or check for an update of this script (2). The element ***_****_com was not found (2) or had no tagName
      INFO | IE login function succeeded
      Exception calling "Navigate" with "1" argument(s): "The requested resource is in use. (Exception from HRESULT: 0x800700AA)"
      At C:\temp\OneDriveMapper.ps1:3365 char:24
      +     $script:ie.navigate <<<< ($baseURL)
          + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
          + FullyQualifiedErrorId : ComMethodTargetInvocation
      
      After numerous attempts, it just gave me "Mapping cannot continue because we cannot detect your username.".
    • Hello Eric/ All,
      
      Im getting the same error message and failing. Anyone got any solution for tis issue?
      
      Thank you,
      Gopi
    • Did you find a solution to this? I am running into the same exact problem. Any tips/thoughts would be greatly appreciated. Thanks
  • script stuck here
    1 Posts | Last post November 20, 2019
    • 
      11/20/2019 17:01:29 | INFO | Retrieving Sharepoint cookie step 2 at https://XXXXXX-my.sharepoint.com/_forms/default.aspx
      11/20/2019 17:01:37 | INFO | Waited for 0 seconds for O4b auto provisioning...
      11/20/2019 17:01:49 | INFO | Waited for 10 seconds for O4b auto provisioning...
  • Works on Windows 2012R2
    1 Posts | Last post July 03, 2019
    • Less a question, than an update.  I was able to successfully run this script on a Windows 2012R2 server.
  • Getting error 1790 on Windows Server 2008 R2(Windows 6) machine
    1 Posts | Last post June 14, 2019
    • We are testing the script on Windows Server 2008 R2(Windows 6) and received the error 1790 and unable to map the OneDrive with the local drive,  have enabled & configured WebDAV from the feature option and but still no luck.
      
      Any idea?
  • Subfolder Permissions not "honored"
    2 Posts | Last post May 24, 2019
    • I have been using ODM to map the default "Documents" library off the default Sharepoint site in Office 365.  Under the Documents folder, I create sub folders.  On those sub folders, I set various permissions.  Mostly, I only grant certain users rights to certain folders.  If you login at Sharepoint Online, you get what you expect.  Users with rights to only a few folders see *only* those few folders.  Admins with rights to all folder see all folders.  Yes, I disable inheritance.  From the web portal, everything works as expected.
      
      Enter mapping a drive with ODM.  ALL USERS have access to ALL FOLDERS - including sub folders and files of sub folders.  I've rebuilt permissions several times on folders, and even waited days for "propagation" of those changes.  No change.  I have "pushed" the changes down on sub folders.  I have double checked there are *no* groups and *no* default permissions on my sub folders.  
      
      Microsoft support says they don't support ODM and won't troubleshoot the issue.
      
      Any ideas?
      
      
      
      
    • I would recommend not mentioning ODM to support, but simply stating the issue is with WebDAV (which is the truth). I haven't seen this issue / can't reproduce it btw, if webdav would ignore permissions this would be a HUGE security issue and escalated big time.
1 - 10 of 197 Items