OneDriveMapper automatically map your OneDrive for Business upon login

This script maps your Onedrive / Sharepoint / Teams document libraries to driveletters (or shortcuts). It can be used in any environment (VDI, RemoteApp, w10 etc).

 
 
 
 
 
4.6 Star
(116)
75,529 times
Add to favorites
Office 365
2/3/2019
E-mail Twitter del.icio.us Digg Facebook
  • Transition from the previous OneDrive for Business sync client
    1 Posts | Last post February 22, 2018
    • Hello,
      
      Is this script compatible with the new OneDrive client detailed below?
      
      https://support.office.com/en-ie/article/transition-from-the-previous-onedrive-for-business-sync-client-4100df3a-0c96-464f-b0a8-c20de34da6fa
      
      The OneDrive for Business client is being depricated and replaced by a OneDrive client for all use cases.
  • Upload limit
    1 Posts | Last post February 16, 2018
    • Hi is there any way to change the upload file size ? 
  • Script No Longer Mapping the Drives
    1 Posts | Last post February 09, 2018
    • Hi Jos,
      
      Today we have found users have lost the drive maps which they already had in place.
      Resending the script to their machine has not re-mapped them and manually running the script on the machine shows errors which refer to it failing to set INETCOOKIES cookie/s. 
      
      Additionally, it states that access was denied trying to connect to the folder within Sharepoint they have access to. IT suggests adding the web site to the trusted site lists and ensure automatic login is enabled, which it is and they are logged in at present. 
      
      I am trying to ascertain which changes, if any, could have caused this to stop running succesfully.
      
      Any help or advice would be greatly appreciated.
      Happy to provide screenshots of errors if required.
      
      Thanks,
      
      Gianni
  • WebDAV Mapping
    6 Posts | Last post February 01, 2018
    • Hi Jos,
      
      This script used to work really well before Microsoft updated their sign-in page. I've just downloaded the new script, but I'm unfortunately running into issues. Specifically, I'm trying to map SharePoint as a WebDav folder, and because I set $authMethod to "ie", it now gets stuck on the Delve.office.com page and refreshes it multiple times, saying: "Attempting to detect username at https://gbr.delve.office.com..., waited for 26 seconds". After 60 seconds, it then fails saying it could not detect a username or password. 
      I have tried to change $authMethod to "native", but then I get the following:
      
      "INFO | Waited for 180 seconds for O4b auto provisioning...
      ERROR | Failed to auto provision onedrive and/or retrieve username from the response URL. Is this user licensed?
      INFO | Will attempt to use auto-guessed value of \\companyname-my.sharepoint.com@SSL\DavWWWRoot\personal\user_companyname_co_uk\"
      
      It then tried to map that personal URL, whereas it should be mapping only the company name (i.e. https://companyname.sharepoint.com). 
      Any help with this would be greatly appreciated!
    • that sounds like the user doesn't have Onedrive, otherwise it shouldn't end up at the Delve page...
    • I having the issue as above:
      
      "INFO | Waited for 180 seconds for O4b auto provisioning...
      ERROR | Failed to auto provision onedrive and/or retrieve username from the response URL. Is this user licensed?
      INFO | Will attempt to use auto-guessed value of \\companyname-my.sharepoint.com@SSL\DavWWWRoot\personal\user_companyname_co_uk\"
      
      It's my account and use OneDrive and fully licenced, any ideas? We are using Azure Simple SSO which is working great!
      
      TIA
    • You'll have to contact me @ my blog (http://www.lieben.nu/liebensraum/contact) with logs and probably a VM so I can reproduce your issue for you.
    • Same here, unable to map drive X: after 180 seconds...
      
    • We are ok now. This was tested and running properly under Horizon View 7.3 as well!, nice script, well done!
  • Does this work on an account with MFA?
    2 Posts | Last post January 26, 2018
    • Does this work on an account with Azure AD Premium MFA enabled?
    • There is a bit of basic support for that in IE auth mode, native doesn't support it
  • System Error 53
    2 Posts | Last post January 26, 2018
    • Hi Jos,
      
      Does it work with SSO via AD Connect (Synchronized Identity)? 
      We ran the script and we're getting the error below.
      ERROR |Failed to contact X: after mapping it to \\onedrivemapper-my....
      
      System error 53 has occurred.
      The network path was not found.
      
      Regards,
      Ted
      
      
    • Yes, it does, 53 usually has something to do with the webdav client, check my blog/FAQ
  • v3.13 ADFS, Workgroup computer
    3 Posts | Last post January 26, 2018
    • Hi guys,
      
      I'm trying to use onedrivemapper on a workgroup computer and I'm getting (401) every time.
      This doesn't happen on domain joined PCs.
      Is there any way to use workgroup PCs with ADFS login?
      
      Exception calling "GetResponse" with "0" argument(s): "The remote server returned an error: (401) Unauthorized."
      At C:\Users\Administrator\Desktop\onedrive-adfs.ps1:364 char:13
    • I've unchecked "Windows Authentication" under global authentication policy - primary authentication and everything is working just fine. Thank you Jos, you're the greatest hero known to technet community!!
      
      Regards,
      Marko
    • thanks! :)
  • Trusted Sites Error
    3 Posts | Last post January 05, 2018
    • I'm using 3.12 and getting this error, even though trusted sites is populated:
      
      (replaced domain with with mydomain for PII concerns)
      
      ERROR | ERROR: detected string error 224 in return code of net use command, this usually means your trusted sites are misconfigured or KB2846960 is missing
      ERROR | failed to contact X: after mapping it to \\mydomain-my.sharepoint.com@SSL\DavWWWRoot\personal\s_kelly4_snhu_edu\Documents, check if the URL is valid. Error:
       System error 224 has occurred.
       Access Denied. Before opening files in this location, you must first add the web site to your trusted sites list, browse to the web site, and select the option to login automatically.
    • I am getting the same error with 3.13. Were you able to fix it?
    • I found if I login to office365 first then it works.
  • Unable to run it via scheduled task or logon script for non-admins
    3 Posts | Last post December 19, 2017
    • SO... if I'm a local admin whether I kick of the script via scheduled task at logon or via GPO, it works just fine. If I'm non-admin it doesn't map any drives, however, if I run it manually (or interactively as scheduled task) it works fine. Any ideas?
      Thank you
    • Probably a UAC setting, what does the log say? what happens if you just restart explorer.exe?
    • Jos, the log did not say anything, it actually says that it mapped the drive successfully. The explorer gets restarted by your script.
      When I disabled UAC, it mapped fine and I was able to see it, now, just need to figure out how to make it work with UAC turned on :-)
      THank you
  • Version 3.13
    3 Posts | Last post December 08, 2017
    • Hi Jos
      
      I think I have the same issue as Kami2082.
      It appears the Microsoft "new sign in experience" has killed the script from working.
      It's been working for months otherwise.
      
      Is V 3.13 the fix for this and if so could you please send me a link
      
      cheers
    • Hi Jos
      
      OK v3.10 is 3.13 
      Also I can report, that if you do not choose to sign in with the new Microsoft user experience the script still works. It's only an issue if you choos
      
       
    • Hi Jos
      
      V3.11 definately works for me !
      
      Your script rocks ! 
41 - 50 of 197 Items