PowerShell for SharePoint 2013: Export TermSet to CSV

The term store is not stored in the content database. It's a responsibility of the Managed Metadata Service.You question - how can I migrate term store from one farm to another?Here is what I found useful to read and use:Migrating managed metadata term sets to another farm on ano

 
 
 
 
 
4.3 Star
(31)
22,188 times
Add to favorites
SharePoint
10/9/2013
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Thanks. It works but..
    1 Posts | Last post April 07, 2016
    • Two small issues:
      1. Does not export Shared/Local Properties
      2. I had to add this line Add-PSSnapin Microsoft.SharePoint.PowerShell before 
       Get-TermSetsCSV -SiteUrl $siteUrl -CSVOutput $outputDir. This is neccessary if not running the script via SharePoint Management Shell.
      
      Other than that, good work. 
  • Quotes
    3 Posts | Last post November 16, 2015
    • Is there a way to remove the quotes around everything?
    • Yes even I am looking for the same.
    • You have to change the locale in you regional settings to the quotes. Then open the file in Excel
  • O365 support
    1 Posts | Last post July 09, 2015
    • Anyone know when this functionality (specifically the Taxonomy scriptlet) will be available for Online instances?
  • Very useful script
    1 Posts | Last post June 23, 2015
    • This is a very useful script during migration process. Thanks
  • More tips for the migration
    1 Posts | Last post March 11, 2015
    • can you provide some more contribution or links for the migration using powershell
  • Is it possible to include Custom Properties?
    1 Posts | Last post February 13, 2015
    • Can you include custom properties such as shared or local properties as part of this export? I'm reluctant to use them unless they can be easily exported/imported but I am struggling to find a way to do this.
  • Problem with UTF8
    1 Posts | Last post May 14, 2014
    • If you are exporting UTF8 characters you will get ? in the resulting file instead of your character. The fix is easy, simply change line 72:
      
      $terms | Export-Csv $CSVFile -notype -encoding "UTF8"