Install SharePoint 2016 Prerequisites offline/online

SharePoint 2016, the prerequisites are almost essentially the same as they were for SharePoint 2013, with one or two differences (e.g. .Net Framework 4.5.2). The following is a list of all of the SharePoint 2016 Prerequisites components you need to download if you are doing an

Scripts.zip
 
 
 
 
 
3.1 Star
(26)
20,354 times
Add to favorites
SharePoint
12/11/2019
E-mail Twitter del.icio.us Digg Facebook
  • Script is Broken
    1 Posts | Last post February 12, 2020
    • KarimSP the SCRIPT is broken you are missing a trailing quote " at the end. ArugmentsList is missing the - switch and your argumentslist itself is broken. You also have incorrect characters in the script. This should be fixed to support a proper SP 2016 Offline Install.
      THIS WORKS:
      $SharePoint2016Path = "C:\Prereqs"
      Start-Process "D:\PrerequisiteInstaller.exe" –ArgumentList "/SQLNCli:$SharePoint2016Path\sqlncli.msi /IDFX11:$SharePoint2016Path\MicrosoftIdentityExtensions-64.msi /Sync:$SharePoint2016Path\Synchronization.msi /AppFabric:$SharePoint2016Path\WindowsServerAppFabricSetup_x64.exe /MSIPCClient:$SharePoint2016Path\setup_msipc_x64.exe /WCFDataServices56:$SharePoint2016Path\WcfDataServices.exe /MSVCRT11:$SharePoint2016Path\vcredist_x64.exe /MSVCRT14:$SharePoint2016Path\vc_redist.x64.exe /KB3092423:$SharePoint2016Path\AppFabric-KB3092423-x64-ENU.exe"
  • Start over
    2 Posts | Last post December 11, 2019
    • This article is wrong in so many places, you really should start over, several links are broken or point to the wrong location, the script has curly quotes in it that break when you try and run it, as others have said several arguments are wrong...I mean dude, start over
    • Dear Trey,
      
      I have checked all the links and they are working for me..Pleaes recheck
  • The String is missing the terminator: ".
    1 Posts | Last post May 03, 2019
    • Windows 2016 Data Center Server
      SharePoint 2016 Setup 
      VMware ESXI 6.5
      
      This fails 
      
      PS C:\temp\sharepoint\scripts> .\Scriptsforsp2016_prereq.ps1
      At C:\temp\sharepoint\scripts\Scriptsforsp2016_prereq.ps1:19 char:52
      + ... er.exe” –ArgumentList“/SQLNCli:$SharePoint2016SP1Path\sqlncli.m ...
      +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      The string is missing the terminator: ".
          + CategoryInfo          : ParserError: (:) [], ParseException
          + FullyQualifiedErrorId : TerminatorExpectedAtEndOfString
      
      
      Thank you
      
      Tom
  • SQL Server 2102 Native client
    2 Posts | Last post May 16, 2018
    • When I run setup.exe to install Sharepoint 2016, it list MS SQL Server 2102 Native client is missing even though is installed. 
      
      Anyway to get around this problem?
      
      Thanks,
      
      Jeff
    • Dear jeff,
      My apologies for late replay..
      Please check which version of the Native client you are trying to install.. it should be 64bit SQL server 2012...
      
      https://www.microsoft.com/en-us/download/details.aspx?id=29065
  • Broken Links
    2 Posts | Last post March 07, 2018
    • Hello Karim,
      You have a broken link on Microsoft identity extensions. This one is alive:
      http://go.microsoft.com/fwlink/?LinkID=252368
      
      Cheers
      Jean
    • Dear Jean,
      Thank you for the link and it has been updated...
  • RAR to ZIP
    2 Posts | Last post February 12, 2018
    • Thank you Karim.  Great work!
      
      Would you mind converting the default download from RAR to ZIP?
      
      Many machines lack the WinRAR client and ZIP would be an easier format to extract on anywhere.
    • Thanks for your Feedback i will update..
  • the script has a bunch of errors
    2 Posts | Last post February 12, 2018
    • missing " quote, no /kb2898850 parameter, on idfx parameter, 
      Bunch of downloads wrong as well
      - SQL client listed is the wrong version (should be SP1)
      - wcfdataservices has to be 5.6, not 5.6.3 as per the link
      
      and there is no SP1 yet (name of the parameter).
    • Dear Hans,
      
      Thanks for your feedback..
      your are correct the WCF data services should be 5.6.0 and the link has been updated
      The remain prereq already exist you can find with links
  • Great article
    1 Posts | Last post August 17, 2017
  • The script does not work but not sure why
    1 Posts | Last post February 03, 2017
    • Use this instead (for SharePoint 2016 slipstreamed with 2016-Dec & Windows Server 2016)
      
      Add-WindowsFeature NET-HTTP-Activation,NET-Non-HTTP-Activ,NET-WCF-Pipe-Activation45,NET-WCF-HTTP-Activation45,Web-Server,Web-WebServer,Web-Common-Http,Web-Static-Content,Web-Default-Doc,Web-Dir-Browsing,Web-Http-Errors,Web-App-Dev,Web-Asp-Net,Web-Asp-Net45,Web-Net-Ext,Web-Net-Ext45,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Health,Web-Http-Logging,Web-Log-Libraries,Web-Request-Monitor,Web-Http-Tracing,Web-Security,Web-Basic-Auth,Web-Windows-Auth,Web-Filtering,Web-Digest-Auth,Web-Performance,Web-Stat-Compression,Web-Dyn-Compression,Web-Mgmt-Tools,Web-Mgmt-Console,Web-Mgmt-Compat,Web-Metabase,WAS,WAS-Process-Model,WAS-NET-Environment,WAS-Config-APIs,Web-Lgcy-Scripting,Windows-Identity-Foundation,Xps-Viewer -Source d:\sources\sxs
  • Quote
    1 Posts | Last post August 19, 2016
    • You've also forgot a closing double quote at the end.
1 - 10 of 11 Items