WSUS Approved Updates Status Report

Provides a status report for approved updates. Every update approved on your server is shown, with a list of the target groups for which it was approved. Within each group, counts

 
 
 
 
 
3 Star
(3)
Add to favorites
Windows Update
9/8/2009
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Report Error
    2 Posts | Last post September 03, 2013
    • Exception calling "GetUpdateServer" with "0" argument(s): "Exception of type 'M
      icrosoft.UpdateServices.Administration.WsusInvalidServerException' was thrown."
      At C:\Users\Administrator\Desktop\Approval.ps1:3 char:86
      +         $wsus = [Microsoft.UpdateServices.Administration.AdminProxy]::GetUpda
      teServer <<<< ();
          + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
          + FullyQualifiedErrorId : DotNetMethodException
      
      Server name:
      Using secure connection:
      Port number:
      The term '-bor' is not recognized as the name of a cmdlet, function, script fil
      e, or operable program. Check the spelling of the name, or if a path was includ
      ed, verify that the path is correct and try again.
      At C:\Users\Administrator\Desktop\Approval.ps1:12 char:6
      +  -bor <<<<  [Microsoft.UpdateServices.Administration.UpdateApprovalActions]::
      Uninstall
          + CategoryInfo          : ObjectNotFound: (-bor:String) [], CommandNotFoun
         dException
          + FullyQualifiedErrorId : CommandNotFoundException
      
      You cannot call a method on a null-valued expression.
      At C:\Users\Administrator\Desktop\Approval.ps1:14 char:17
      + $wsus.GetUpdates <<<< ($updateScope) | foreach {
          + CategoryInfo          : InvalidOperation: (GetUpdates:String) [], Runtim
         eException
          + FullyQualifiedErrorId : InvokeMethodOnNull
      
    • This code appears to be designed to run on the wsus server directly.  
      
      I hope you figured this out by now.  I'm just adding it to this thread so other people might find the answer quickly.
  • Script doesn't work
    3 Posts | Last post November 15, 2011
    • I keep getting an error on the | sign at the end of line 2:
      
      VBScript
      [reflection.assembly]::LoadWithPartialName("Microsoft.UpdateServices.Administration") | out-null
      
      Error message:
      Script: <name.vbs>
      Line: 2
      Char: 87
      Error: Invalid character
      Code: 800A0408
      Source: MS VBScript compilation error
      
      I've tried it on Windows XP and Windows Server 2003, with the same result.
    • You need to install Powershell for this to work - it isn't VBScript code.
      
      Hope this helps.
    • Good point Warren. Easy to overlook.
  • FYI you have an invalid character in your script
    2 Posts | Last post November 15, 2011
    • Invalid character in the script shows as a ` at the end of the line
      $updateScope.UpdateApprovalActions = Microsoft.UpdateServices.Administration.UpdateApprovalActions]::Install 
      
      `  
      
      -bor [Microsoft.UpdateServices.Administration.UpdateApprovalActions]::Uninstall 
      
    • Thanks for the catch, Casey!
  • there is no script output
    1 Posts | Last post May 31, 2011
    • Hi there,
      
      I do not know the reason why, when I execute the script in PS 2.0, there is no output of any kind, no errors, no information displayed in the console.
      
      Any ideas?
      
      Thanks in Advance