Automatic syncing of configuration changes between 2 DHCP failover servers

DHCP Failover is a new feature in Windows Server 2012 which provides for high availability of DHCP service. The PowerShell tool provided here allows an admin to setup automatic synchronization of configuration changes between 2 DHCP servers which have been configured for failover

 
 
 
 
 
4.5 Star
(17)
16,041 times
Add to favorites
Networking
2/19/2014
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Auto-adding new scopes to failover relationship?
    1 Posts | Last post August 07, 2014
    • Hello,
      
      Do you think it would be possible in future releases of this tool to automatically add new scopes to the failover relationship?  That way, it really would be a set and forget tool.
      
      Thanks.
  • Do you have a version for 2012 R2?
    2 Posts | Last post July 17, 2014
    • Or will this work with 2012 R2
    • To answer my own question a powershell command will work for 2012 R2
      http://britv8.com/dhcp-2012-r2-static-reservations-replication-not-working/
      
  • Powershell scripts runs manually but not under schedual
    3 Posts | Last post March 12, 2014
    • When the scripts is run manually ( right click run in power shell) it runs fine no issues
      when run by scheduled task it says its running but never syncs
      
      took me a while to work out and its not mentioned here or in the doc instruction 
      but as the script has come from the internet you need to unblock it (right click on the .ps1 file goto properties and click unblock, it will then be aloud to run on the scheduled task )  otherwise you get a security warning every time you run the script that you have to allow or it doesn't run but of course you cant see this warning as its running hidden!
      
      Gaz6699
      
    • Thanks Gaz for the feedback. Will add it to the document and publish a revision.
    • Gaz6699, we have posted a new version of the doc with guidance to unblock running the script. Thanks!
  • Automatic sync not working, and no log file is created
    2 Posts | Last post January 08, 2014
    • Hi.
      I have setup hot-standby between our 2 2012 dhcp servers according to the instructions. The user running the dhcpfailoverautoconfigsynctool is member of: DHCP administrators in the domain, and the dhcp administrator group locally on both servers. The user are also local admin on both servers, and can run batch jobs.
      
      Problem: The last run result gives the code: (0x41301). And there is no log file created in the root folder where the .ps1 file is located...
      
      Any suggestions to what i may be doing wrong? :)
      -Terje
    • Hi Terje,
      The code Ox41301 indicates that the task is running. Have your tried changing a scope property and check if its being synced to the partner DHCP server.
      If sync is not working, can you try to end the task manually and then run it again to see if the log file gets generated and sync is done.
  • Period Syncing
    4 Posts | Last post June 21, 2013
    • Hi
      
      The periodic syncing doesn't appear to be working for me? I was just doing some testing and if I increase/decrease the IP address range in the scope, it doesn't sync. I've got the interval set to 30mins, and even pushed it back to 3mins.
      
      The automatic syncing is working fine, so if I go and create a new reservation in the scope the other changes are replicated, but I'd prefer if the periodic sync worked ok.
      
      Cheers
      Gary
    • Hi Gary,
      
      Thanks for reporting the issue.
      We are looking into this and will soon get back to you with a fix for the same.
    • Hi Gary,
      
      The issue has been fixed.
      The periodic sync should work now.
    • Thank you, the update is greatly appreciated. I'll test out the new script to make sure it's all ok.
  • Auto syncing not working
    3 Posts | Last post June 07, 2013
    • Hello,
      
      I have followed the instructions in the guide, but auto sync is not working when I make a change on the primary server.  I have 2 servers set up in standby mode. I have installed DFACS on the primary server. Manual replication works fine.  When I run the install.ps1 the scheduled task is created successfully, and the task runs successfully on startup.  When I create a test scope on the primary server nothing happens, there is no log file written and replication never occurs.  Any ideas?  I didn't change any of the default options in the xml file or in the scheduled task (except for setting it to run if no one is logged on), so maybe I missed something important.
      
      Thanks
    • Hi cb1locker,
      
      The tool syncs the configurations of the scopes that participate in failover. 
      Can you check if the test scope that you created is a member of the failover relationship? Any new scope added to a server is not added to the existing failover relationships.
      
      Once you add the scope to a failover relationship, it will be created automatically on the partner server by the DHCP server itself. 
      
      In case you added a new relationship, restart DFACS. Post that DFACS will make sure that any changes in the scope configurations are replicated on the partner server.
    • Thanks for the info, adding the scope to the failover relationship replicated it immediately.  Thanks again!
  • Use gMSA for SyncTool?
    2 Posts | Last post April 27, 2013
    • I want to use a group Managed Service Account for the sync tool. 
      
      The following blogpost says that you can only assign a gMSA to a task when you create the task through PowerShell. So therefor I will need to build a custom Task "installation" command. (http://blogs.technet.com/b/askpfeplat/archive/2012/12/17/windows-server-2012-group-managed-service-accounts.aspx)
      
      Is this something that you have tested/recommend?
      
      
      Best Regards,
      
      Thomas
      
    • Hi Thomas,
      
      The task is being created through SCHTASKS.
      If you have created your gMSA, you just need to make some small changes in the file install.ps1.
      Replace the last line in install.ps1 with the following two lines
      $username="contoso\gmsatest$" #(replace contoso\gmsatest with your domain/gmsa account. $ is required in the end.)
      
      SCHTASKS /Create /SC "ONSTART" /RL HIGHEST /DELAY 0001:00 /TN $taskName /TR $taskRun /ru $username /rp 
      
      Press Enter without any other input when prompted for password.
      Post this go and confirm in Task Scheduler that the task has been created to run with your gMSA whether the user is logged in or not. Right click on the task and press Run. You are good to go now.
      Please make sure you have given appropriate privileges to the gMSA (added it to DHCP Administrators group).
      
      Thanks and Regards,
      teamdhcp
21 - 27 of 27 Items