DSC Resource Kit (All Modules)

The DSC Resource Kit is a collection of experimental DSC Resources released by the PowerShell Team, designed to help you get started with DSC. These resources allow you to configure Active Directory, SQL Server, IIS, Hyper-V, RDSH, and more.

 
 
 
 
 
4.7 Star
(52)
60,846 times
Add to favorites
8/7/2015
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Difference between different way of using PowerShell?
    1 Posts | Last post November 03, 2015
    • Do we have a simple way to defined when to use native PowerShell script or PoweShell work flow or PoweShell DSC?  
  • publish as nuget
    1 Posts | Last post June 11, 2015
    • When will you be publishing these extensions as Nuget packages to make it easeyer to take advantage of in Visual Studio projects?
  • Getting MSFT_xChrome' could not be loaded in Azure VM
    1 Posts | Last post May 21, 2015
    • I have a simple powershell script that is attempting to create firewall rules, setting IE enhanced settings and install chrome.
      
      In my script 
          Import-DscResource -ModuleName xChrome
      
      I also tried importing like this because xChrome had an example that was using -module
      Import-DscResource -module xChrome
      	
          MSFT_xChrome chrome
          {
      	Language = $Language
      	LocalPath = $LocalPath
          }
      
      I created a zip file with Publish-azurevmdscconfiguration and create the zip file.
      In my zip file I verified that xChrome is present.
      
      I manually uploaded the DSC extention using the new azure portal on a win 2012 R2 VM.
      
      The module 'MSFT_xChrome' could not be loaded. For more information, run 'Import-Module MSFT_xChrome'.
      At C:\Packages\Plugins\Microsoft.Powershell.DSC\1.10.1.0\DSCWork\rajdsctest2-modules-20150521-203400.1\SetupSplunkServer.ps1:19 char:5
      +     Node $NodeName
      +     ~~~~
          + CategoryInfo          : ObjectNotFound: (MSFT_xChrome\MSFT_xChrome:String) [PSDesiredStateConfiguration\node], ParentContainsErrorRecordException
          + FullyQualifiedErrorId : CouldNotAutoLoadModule,PSDesiredStateConfiguration\node
      
      
      I also invoke xNetworking and xIEEsc and both of them have no issues but xChrome is failing.
      
      running Get-AzureResource confirms that xChrome is not present even though it was present in the uploaded zip file.
      
      Let me know if you have any suggestions to fix this issue.
      
  • GitHub?
    3 Posts | Last post April 27, 2015
  • Frendly reminder.
    1 Posts | Last post April 14, 2015
    • Example config looks like httpd.conf from Apache!
      Many years passed since and winding trail bring us back to config files like in Unix Wow!
      
  • I couldn't see the modules in xWebAdminiStration
    2 Posts | Last post April 02, 2015
    • o   xIisModule
      
      o   xWebApplication
      
      o   xWebAppPool
      
      o   xWebConfigKeyValue
      
      o   xWebsite
      
      o   xWebVirtualDirectory
       These modules were not available in Wave 10. Is there any other way they used when compared to Wave 9 and Wave 8
    • As of xWebAdministration 1.3.2.4, all missing files should be back in all TechNet zip files. Sorry for the confusion and the delay. 
  • DSC Resource Kit Wave 9 zip is missing Modules
    2 Posts | Last post April 02, 2015
    • If you compare the ./xWebAdministration/DSCResources folder in the wave 9 zip with previous ones and the individual zip for the xWebAdministration module you will notice that the wave9 zip is missing 5 modules.  Is this intentional?  Is this supposed to be an update zip and if so which zips do I have to install first?
      
      The missing modules are:
      xIisModule
      xWebAppPool
      xWebConfigKeyValue
      xWebDeploy
      xWebsite
      
      I haven't checked the other module collections.
    • As of xWebAdministration 1.3.2.4, all missing files should be back in all TechNet zip files. Sorry for the confusion and the delay. 
  • xService is not idempotent
    4 Posts | Last post March 30, 2015
    • Hello,
      I created a DSC script with xService resource but when the windows service already exists, the script fails with the following error:
      
      PowerShell provider MSFT_xServiceResource  failed to execute Test-TargetResource functionality 
      with error message: The service to create already exists 
          + CategoryInfo          : InvalidOperation: (:) [], CimException
          + FullyQualifiedErrorId : ProviderOperationExecutionFailure
          + PSComputerName        : localhost
      
      
      Here's the DSC snippet:
      
      Configuration XptoBTConfiguration 
      { 
        param ($MachineName)
      
        Import-DscResource -Module xPSDesiredStateConfiguration
      
        Node $MachineName 
        { 
          xService XptoUnitService
          {
              Name = "UnitService"
              Ensure = "Present"
              Description = "BT Xpto - Unit Service"
              BuiltInAccount = "LocalService"
              StartupType = "Automatic"
              State = "Running"
              Path = "$xptoDestDir"
          } 
        } 
      }
      
      DSC scripts should be idempotent right? I should be able to run then how many times I want correct?
      
      Thanks for your help,
      Pedro
    • Try Using Ensure = "Absent" It will delete the service. and If you want to install the service, use Ensure = "Present", it will create a service for you. For Every DSC Resource the concept is same.. 
      
    • PFFreitas,
      
      DSC Scripts and Resources should be idempotent.  We are working on a fix for the issue; thank you for bringing it to our attention.
      
      Thanks,
      John Slack
      PowerShell Team
    • Do we have an update when this will come out? This is a pretty big deal, and it keeps me from using this in a production scenario. 
  • String file for PSDSCxMachine missing
    1 Posts | Last post March 26, 2015
    • Seems that with wave 10 when i try to configure a cluster and then install SQL it allways fails. 
      
      When using the WaitForAll command i get the following error
      Invoke-CimMethod : Cannot find the Windows PowerShell data file 'PSDSCxMachine.strings.psd1' in directory
      'C:\Windows\system32\WindowsPowerShell\v1.0\Modules\PSDesiredStateConfiguration\en-US\', or in any parent culture
      directories.
      
      I am not sure if it was missed out of wave 10 or if it should be there in a folder and for some reason all of my machines are missing it.
      
      Thanks
  • xPackage - can not deinstall remote package
    1 Posts | Last post March 07, 2015
    • Hello all,
      
      xPackage can install software with "http://" path, but  can't deinstall it.
      
      Example:
              xPackage testSilverlight {
                  Ensure = "Present"
                  Name   = "Microsoft Silverlight"
                  Path   = "http://download.microsoft.com/download/F/8/C/F8C0EACB-92D0-4722-9B18-965DD2A681E9/30514.00/Silverlight.exe"
                  Arguments  = "/q /ignorewarnings /noupdate"
                  ProductId = ""
              } 
      
      This works fine - downloads and installs everything as needed.
      
      In opposite the same code with Ensure = "Absent" falls with errors:
      VERBOSE: [WIN-AIMI87IRJK6]:                            [[xPackage]testSilverlight] Validate-StandardArguments, Path was http://download.microsoft.com/download/F/8/C/F8C0EACB-92D0-472
      2-9B18-965DD2A681E9/30514.00/Silverlight.exe
      VERBOSE: [WIN-AIMI87IRJK6]:                            [[xPackage]testSilverlight] The path extension was .exe
      VERBOSE: [WIN-AIMI87IRJK6]:                            [[xPackage]testSilverlight] Package configuration starting
      VERBOSE: [WIN-AIMI87IRJK6]: LCM:  [ End    Set      ]  [[xPackage]testSilverlight]  in 0.0780 seconds.
      PowerShell DSC resource MSFT_xPackageResource  failed to execute Set-TargetResource functionality with error message: The given Path 
      (http://download.microsoft.com/download/F/8/C/F8C0EACB-92D0-4722-9B18-965DD2A681E9/30514.00/Silverlight.exe) could not be found 
          + CategoryInfo          : InvalidOperation: (:) [], CimException
          + FullyQualifiedErrorId : ProviderOperationExecutionFailure
          + PSComputerName        : localhost
       
      The SendConfigurationApply function did not succeed.
          + CategoryInfo          : NotSpecified: (root/Microsoft/...gurationManager:String) [], CimException
          + FullyQualifiedErrorId : MI RESULT 1
          + PSComputerName        : localhost
      
1 - 10 of 22 Items