Easily Create Office 365 Shared Mailboxes using Powershell

Easily create Office 365 Shared Mailboxes using this Powershell Script

 
 
 
 
 
5 Star
(4)
5,066 times
Add to favorites
Office 365
1/18/2014
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • account created on-prem
    1 Posts | Last post June 06, 2018
    • I ran the script and it created the mailbox on-prem not Exchange Online. What do I need to change in order to create the mailbox online? Thanks in advance.
  • Setting Read Only permissions on the shared mailbox - not working! Why?
    1 Posts | Last post November 24, 2012
    • I received: "Setting AutoMapping option to true for non-FullAccess rights is not allowed. AutoMapping=true option can only be used together with FullAccess permission."
      Is a different way to do this?
      Perhaps  ReadPermission not mean Read Only...
  • which domain for the mailbox
    2 Posts | Last post September 27, 2012
    • Nice article Alan.
      
      But I have this doubt: on one hand, you ask the user to enter the SharedMailboxUserName (in your example, shared@yourdomain.com).
      
      On the other hand, when you call New-Mailbox, you pass "shared" (whithout the domain) within the Alias parameter.
      
      As a matter of facts, the mailbox "shared@mytenant.onmicrosoft.com" is created.
      However, you tell the user that shared@yourdomain.com mailbox was created.
      
      I guess that you can't pass a string containing the symbol "@", but I'm wondering what I should do to create a list with a domain other than mytenant.onmicrosoft.com.
      
      Thank you
      
      Mauro
    • Hello Mauro,
      
      Thanks for bringing this to my attention, you are absolutely right.  I have modified the script to fix this problem.
      
      If you want to change the email address of a mailbox you've already created you can connect to Office 365 using Powershell and use the following cmdlet
      
      Set-Mailbox shared -PrimarySmtpAddress shared@yourdomain.com
      
      Thanks again for pointing this out and let me know if you have any further problems.
      
      Regards,
      
      Alan