Azure SQL Database Elastic database tools: Shard Elasticity

Shard Elasticity is at the heart of elastic database tools applications as it enables cloud admins to utilize the Azure platform to dynamically shrink and grow database resources in order to optimize the performance and/or cost requirements of their applications.

 
 
 
 
 
4 Star
(2)
1,065 times
Add to favorites
Windows Azure
8/7/2015
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Scripts only work the first time
    3 Posts | Last post April 21, 2015
    • I have been playing around with the scripts above. The first time that I run the scripts, everything works fine. I get the Shard Map Manager Database created as well as today's shard. I then delete those 2 databases through Enterprise manager using the commands
      
      drop database [Shard_20150419]
      drop database [ShardMapManagerDb]
      
      When I run the scripts again, the databases are created, but there are no tables inside the databases. The scripts complete without errors and the output from the output window looks the same as the first time I created them. What's going on here? Do I need to do more to delete the databases than just drop them? When I wait another day, I get the same behaviour. The first time it works, then second time, empty databases. I have tried dropping and recreating the jobs in between runs, and that doesn't fix the problem. I have also tried publishing the jobs, and that doesn't fix the problem. I really need to know what is going on here before I can continue evaluating this technology.
      
      Regards,
      Paul
    • Hi Paul,
      
      Thanks for the question. The sample scripts do not actually create a schema in the newly provisioned shard. In the ProvisionByDate.ps1 script, when the current day's database is not detected a new database is created by the New-SqlDatabase() method in the SqlDatabaseHelpers.ps1 script. I'd love to know more about your scenario and how I can help. If you have follow-up or additional questions that would be beneficial for the greater good, please post them here.  If you want to talk more about your scenario, please email me at joseidz @ microsoft dot com.
    • I'll send you some email, thanks.
  • not a question, is something wrong with the zip contents
    2 Posts | Last post October 09, 2014
    • Hi,
      Only to point that if you download the zip file in this example, inside there is the module folder BUT is not correctly typed, if you want the asset to be properly uploaded to Microsoft Azure you have to change the folder dame 
      
      from (as in the current ShardElasticity.zip package):
      
      ShardElastcityModule
      
      to:
      
      ShardElasticityModule
      
      Regards!
      
      Miguel Lopez | Augurarte - tested on October, 9th
      
    • @Miguel, thank you for the feedback!  The naming has been fixed.