Getting started with Script Browser 1.3.2

Download: http://www.microsoft.com/download/details.aspx?id=42525 Script Browser enables you to search and reuse over 9000 script samples from within your scripting environment. It puts thousands of scripts at your fingertips when you automate your IT.

 
 
 
 
 
4.4 Star
(10)
6,699 times
Add to favorites
Applications
9/25/2014
E-mail Twitter del.icio.us Digg Facebook
  • Please update the url or remove if not longer available.
    1 Posts | Last post December 10, 2016
    • 
      The links supplied and the fixed link below do not resolve.
      
      http://powershelltaskforce.com/2014/04/problem-with-the-new-script-browser-add-on-for-ise-and-culture-settings/ 
      
  • How to download this add-on ?
    5 Posts | Last post November 30, 2016
    • How to download this add-on ?
      There is no download link.
      
      Thanks.
    • Hello,
      
      We will update this documentation when the download link is ready. Please stay tuned.
      
      Best Regards,
      Microsoft All-In-One Script Framework
    • Hello,
      
      It's been two (2) years since the download link went dead.
      When is it going to be available again?
      
      Thank you.
    • Install-Module -Name ScriptBrowser -Force -Verbose
      
      You may get a prompt to install NuGet.
      Credit to: https://4sysops.com/archives/my-favorite-windows-powershell-ise-add-ons/
    • Hi Victor,
      
      Your answer is right! But I would like to be informed (from the team) instead of searching in the dark.
      Thank you for your help!
  • Is this project dead
    1 Posts | Last post June 07, 2016
    • Last question 2 years ago and url leads to a page that is no longer available.  Is this project abandoned?  
  • How do I make the functions in the script available in the command line?
    1 Posts | Last post May 12, 2014
    • Am I supposed to copy and paste the script into the console each time, or is there a way to permanently add these scripts to the terminal?
  • Error on Install with Document redirection
    2 Posts | Last post April 25, 2014
    • Hello, We have "My Documents" redirected in our environment which seems to cause an issue on install. Error is:
      
      Error 1001. An Exception Occurred during Commit phase of the installation. This exception will be ignored and installation will continue. However, the application might not function correctly after installation is complete. --> Access to the path '\\remoteserver\documents$\username' is denied.
      
      But the install then rolls back rather than ignoring the exception as one would expect from the error text. I've worked around this by just running it as a user without that policy, but it would be nice to get that fixed.
    • We are fixing the 1001 install problem in the upcoming 1.1 update of Script Browser.  Here is a temp workaround:
      
      Start a new cmd command prompt as administrator (run as administrator), navigate the ScriptBrowser.msi file, and run the msi.  
      
      After you launch the Script Browser after the successful installation, you may want to change the sample download location in the settings immediately to a local folder.   We do not support downloading samples to a shared folder in the current version.
      
  • Error when running the $Profile script
    2 Posts | Last post April 18, 2014
    • The line below generates an error which prevents the Script Browser from working.
      $scriptBrowser = $psISE.CurrentPowerShellTab.VerticalAddOnTools.Add('Script Browser', [ScriptExplorer.Views.MainView], $true)
      
      This is the error message:
      Exception calling "Add" with "3" argument(s): "Cannot create element because an exception occurred with the message: The specified registry key does not exist..
      Parameter name: controlType"
      
      The error message does not list the registry key that does not exist.
      Thoughts?
      
    • Hello,
      
      Thank you for your feedback. We are investigating this issue. Please stay tuned.
      
      Best Regards,
      Microsoft All-In-One Script Framework
  • I get an error when running the profile
    2 Posts | Last post April 18, 2014
    • Exception calling "Add" with "3" argument(s): "Cannot create element because an exception occurred with the message: Input string was not in a correct format..
      Parameter name: controlType"
      At [path to the profile, removed by me due to reasons]\Microsoft.PowerShellISE_profile.ps1:6 char:1
      + $scriptBrowser = $psISE.CurrentPowerShellTab.VerticalAddOnTools.Add('Script Brow ...
      + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
          + FullyQualifiedErrorId : ArgumentException
       
      Exception setting "SelectedAddOnTool": "Value cannot be null.
      Parameter name: value"
      At [path to the profile, removed by me due to reasons]\WindowsPowerShell\Microsoft.PowerShellISE_profile.ps1:8 char:1
      + $psISE.CurrentPowerShellTab.VisibleVerticalAddOnTools.SelectedAddOnTool = $scrip ...
      + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          + CategoryInfo          : NotSpecified: (:) [], SetValueInvocationException
          + FullyQualifiedErrorId : ExceptionWhenSetting
      
      How do I resolve this?
      
      Thanks.
    • Hello,
      
      Thank you for reporting the issue.
      We have found the problem and fixed it in our source control.  The issue impacts users whose locale treats double number as #,#### (e.g. 1,2).  Before we release the 1.1 version of Script Browser in the near future to include the fix and some small features, would you please try the following workaround that a MVP figured out? 
      
      http://powershelltaskforce.com/2014/04/problem-with-the-new-script-browser-add-on-for-ise-and-culture-settings/ 
      
      Best Regards,
      Microsoft All-In-One Script Framework