Reset WSUS Authorization and get new WSUS SID

Sometimes Machines will get updates from WSUS and not report. This is usually caused by Duplicate WSUS SIDs shared between machines. This is usually a result of cloning or deploying from a template. Once you run this script the machine will delete its current SUS ID and reach out

 
 
 
 
 
4.8 Star
(25)
42,585 times
Add to favorites
Windows Update
12/20/2013
E-mail Twitter del.icio.us Digg Facebook
  • Or like this
    2 Posts | Last post August 08, 2019
    • Personally I also make the folder on the computer and in a GPO computer
      
      $path = "c:\windows\SoftwareDistribution" 
      
      Stop-Service wuauserv 
      
      Push-Location
      Set-Location -Path "HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate"
      Remove-ItemProperty . -Name SUSclientid
      Remove-ItemProperty . -Name SusClientIdValidation
      Remove-ItemProperty . -Name PingID
      Remove-ItemProperty . -Name AccountDomainSid
      Pop-Location
      
      Remove-Item -path $path -force -recurse
      
      Start-Service wuauserv
      
      Invoke-Command {wuauclt.exe /resetauthorization /detectnow}
      
    • wuauclt.exe /resetauthorization /detectnow worked on Windows 2016. 
      
      Thanks. :)
  • Add this to make it work on Server 2016
    1 Posts | Last post June 28, 2019
    • the line 
      wuauclt.exe /resetauthorization /detectnow
      
      will work on all servers except 2016.
      
      In 2016 you will need the following line:
      usoclient.exe startscan
      
      Hopefully that helps.
  • Works with an *
    1 Posts | Last post June 14, 2019
    • Ping key will fail
      ACcountDomainSID will fail
      
      Those 2 have failed for me 100% across 2008R2/2012R2/2016
      
      However this has worked for me 100%. 
      1. Run Powershell as administrator
      2. Run this command/bat.
      3. Retry Windwows update. Once Windows Update updates the time of the last check to your current time, refresh WSUS Unassigned Computers. You will see your missing server.
      
      No need to reboot.
  • THANK YOU! This works!!
    3 Posts | Last post February 02, 2019
    • Thank you thank you THANK YOU! After much searching and no luck, I finally found this and it resolved the issue of my Windows 10 system not showing up in WSUS. 5/5 stars!
    • This script worked perfectly with my Windows Server 2012 R2, Thanks for the script.
    • +1 thanks!
  • Windows 8 and above
    1 Posts | Last post January 31, 2018
    • Somebody has done this in windows 8 or 10?
      Im facing some problems at my office, the machines apply the GPO, but dont show on WSUS dashboard
      
      The script works for windows 7 fine, but any other version with no success
  • Run On Every Login
    2 Posts | Last post October 02, 2014
    • Thanks for script. Can we run this from Group Plicy? it will reset wsus id for every time this can be problematic?
    • You could run from GP but i don't recommend it. I would only run this when you have issues on individual machines 
      Imaging a machine is generally what causes duplicate SID's. which is generally the problem people have and need this script for.