Reset Windows Update Agent

This Script allow reset the Windows Update Agent resolving issues with Windows Update.

ResetWUEng.zip
 
 
 
 
 
4.6 Star
(197)
568,105 times
Add to favorites
Windows Update
11/18/2019
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Empty pages of Help.chm
    2 Posts | Last post June 05, 2017
    • I had a problem that pages of help.chm file were empty. I point out that in this case it is needed to view the file properties and unblock it.
    • Hi Petr,
      
      This issue is presented with all files downloaded from the internet. The SmartScreen Filter is in charge of blocking them to protect your PC.
      
      I will include this information in the next update.
      
      Thanks.
  • It works!
    2 Posts | Last post June 05, 2017
    • First tool that's ever worked against the purpetual "Checking for Updates..." message
    • Thanks EliotMez
  • Download empty
    3 Posts | Last post June 05, 2017
    • The zip file that is downloaded is empty.  The spanish version seems to work.  Anybody else see the problem?
    • Hi, KohaiUT! For me, the download is working fine. Just a guess: maybe your antivirus program is detecting it as some kind of malware and deleting the script files from within the zip file.
    • Hi,
      
      Please try download in https://github.com/ManuelGil/Script-Reset-Windows-Update-Tool
  • Tool not working
    2 Posts | Last post June 05, 2017
    • The zip file is only 626KB and the help file instructions  is 615 KB and the cmd file is only 5 Kb. when it prompts you to enter any key to run as administrator, the screen blanks out when you press a key. Is this a complete file ? 
    • Hi Fred,
      
      This tool is a command-line script, read the help.chm for the use.
  • Trojan in the launcher?
    2 Posts | Last post June 05, 2017
    • Hi,
      I can't use this tool because the launcher exe is removed. It was said:The file was marked as a Trojan by several antivirus. Below is a detailed review by the https://www.virustotal.com/ page.
      What can I do?
    • Hi Flattermann,
      
      Run this tool as administrator.
  • testing review
    2 Posts | Last post June 05, 2017
    • testing review 5/22/17
    • Thanls.
  • Cannot Access Windows Services
    6 Posts | Last post June 05, 2017
    • First, thank you for posting this tool!  I ran it because I cannot get Microsoft's latest Cumulative Update (KB4013429) to install.  http://news.softpedia.com/news/easy-fix-for-windows-10-cumulative-update-kb4013429-issues-514030.shtml recommended running your tool.  Good or bad after running your script I still cannot install KB4013429.  But worse I have lost all access to Windows Services.  I get the message, "An Administrator has blocked you from running this app.  For more information  contact the administrator.  mmc.exe"  Can you help me get it turned back on?  (As an FYI, restarting did nothing.  Also I cannot run Windows Services as an Administrator either. :) )
    • I had to go into my registry wcnsvc and re-enable my user permissions to "Full Control".  Apparently a part of your script is that you changed this from "Full Control" to "Read Only".
    • Hi William,
      
      This tool removes some Firewall settings, DNS settings and more.
      
      However, it is not designed to add restrictions to system control.
      
      I will be attentive for another similar situation.
      
      Thanks!
    • I have the exact same issue
    • William, can you tell me where in the registry do you reset permissions to full please.  Thank you. 
    • Hi Chrismo16 and SKB10,
      
      The key Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate contains the information regarding the policies of Windows Update.
      
      For more information see:
      
      https://support.microsoft.com/en-us/help/326686/you-receive-one-or-more-error-messages-when-the-system-administrator-disables-windows-update-or-microsoft-update
      
      http://getadmx.com/?Category=Windows_10_2016&Policy=Microsoft.Policies.WindowsUpdate%3A%3ARemoveWindowsUpdate
      
      
  • Download was interrupted
    4 Posts | Last post June 05, 2017
    • Running Windows 7 Home 64 bit + 32 bit with IE 11 and WebRoot SecureAnywhere. Unable to complete download of ResetWUEng.zip even after disabling Webroot.  Message appears at apx 1 minute shy of completion that "Download was interrupted".  Could you suggest what might cause the interruption and how to fix?  
      As to Windows Update, have been able to install a few files but many fail.
      Thanks, Manuel.
    • Hi Cyber,
      
      Try download this in https://github.com/ManuelGil/Script-Reset-Windows-Update-Tool
      
      Thanks!
    • So we use this on Power Shell, right?
    • Hi Nguyen,
      
      This tool is the command-line script. You have run as administrator.
      
      Seen this video: https://www.youtube.com/watch?v=tT9NEXYOSBI
      
      Thaks.
  • Upgrade
    4 Posts | Last post April 14, 2017
    • Can you upgrade the script to support Windows 10 Creators Update?
      Will be useful for the Community support.
      Thank You!
      
      Franco Leuzzi - Microsoft® MVP 9th Year - Windows and Devices for IT - System Administration - Hardware\Software. 
      
      FrancoLeuzzi @ alice.it
      
      
    • The Windows 10 Creators Update Will be officially published on April 11 and some testing is required before an update this script to this release.
      
      At the moment I am performing the necessary tests to publish a new version.
      
      I am grateful to include this version in your publications on answers.microsoft.com and include the credits the development.
      
      Grazie mille.
      
    • All Done!!
    • Perfect:
      Pubblicato:
      https://answers.microsoft.com/it-it/windows/wiki/windows8_1-update/ripristino-di-windows-update-windows-vista-7-81-e/880067ce-cb1b-428d-8021-ecbe04dd6393
      
       Thank you !   :-)
  • RebootRequired
    2 Posts | Last post April 11, 2017
    • My problem was the continual reboot required loop. As fixed by reading https://appuals.com/restart-your-computer-to-install-important-updates-loop/
      
      i.e. delete key: 
       HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired
      
      It wasn't fixed by your great tool.
    • Hi Alan,
      
      This script isn't a definitive tool for Windows Update troubleshooting, it is a support tool for restore Windows Update components.
      
      In the same way already included this change in the registry for a new version of this tool
      
      For more information check the file: Help.chm
      
      Thanks!
61 - 70 of 89 Items