Reset Windows Update Agent

This Script allow reset the Windows Update Agent resolving issues with Windows Update.
4.6 Star
570,300 times
Add to favorites
Windows Update
E-mail Twitter Digg Facebook
  • Upgrade
    4 Posts | Last post April 14, 2017
    • Can you upgrade the script to support Windows 10 Creators Update?
      Will be useful for the Community support.
      Thank You!
      Franco Leuzzi - Microsoft® MVP 9th Year - Windows and Devices for IT - System Administration - Hardware\Software. 
      FrancoLeuzzi @
    • The Windows 10 Creators Update Will be officially published on April 11 and some testing is required before an update this script to this release.
      At the moment I am performing the necessary tests to publish a new version.
      I am grateful to include this version in your publications on and include the credits the development.
      Grazie mille.
    • All Done!!
    • Perfect:
       Thank you !   :-)
  • RebootRequired
    2 Posts | Last post April 11, 2017
    • My problem was the continual reboot required loop. As fixed by reading
      i.e. delete key: 
       HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired
      It wasn't fixed by your great tool.
    • Hi Alan,
      This script isn't a definitive tool for Windows Update troubleshooting, it is a support tool for restore Windows Update components.
      In the same way already included this change in the registry for a new version of this tool
      For more information check the file: Help.chm
  • Server usage?
    4 Posts | Last post April 11, 2017
    • Has anyone tried this script on a 2012 or 2012 R2 server?
    • Getting ready to try it tonight on a Microsoft Windows Server 2012 Standard Edition, 64-bit (build 9200)
      Will report back.
    • It worked for us on Server 2012 Standard!
    • Hi Carl and Xcreed,
      The Windows Server and Windows for Home share some builds.
      | Windows 8
      | Windows Server 2012	||	6.2.9200
      | Windows 8.1
      | Windows Server 2012 R2	||	6.3.9600
      | Windows 10
      | Windows Server 2016	||	10.0.14393
      This tool is compatible with Windows 8, 8.1 and 10. Also compatible with Windows Server 2012, 2012 R2 and 2016, however, it is not recommended to use in Windows Server since it can eliminate some configurations of Firewall, Domain and others...
  • In the script - a path and a file do not exist
    2 Posts | Last post October 21, 2016
    • 1 In the script, the path to the qmgr files does not exist [KB971058 has not been changed, it also still points to this path]
       "%ALLUSERSPROFILE%\Application Data\Microsoft\Network\Downloader\qmgr*.dat"
       but this one does
       2 Similarly, I cannot find this file anywhere [I included checking on a computer that had items listed in its download queue at Settings, Update]
       Any ideas?
    • Hi Denis,
      I updated this files today 10/21/2016 and I have added the new location in this tool.
      Thanks for your collaboration.
  • Another AV blocking
    2 Posts | Last post October 17, 2016
    • Hi,
      When downloading Trend Micro is blocking the file as Trojan.
      Not sure why your .zip is triggering this, I'm not having this issue with other scripts.
    • Hi Kunzite_,
      The file "Info.txt" described with more detail the issue.
      Also, you can see in the comments information regarding this file.
  • 0kb
    2 Posts | Last post October 17, 2016
    • Hi, 
      same problem here... 
      IE, EDGE, Firefox. 0kb .zip archive. 
    • Hi Tomáš Kalabis,
      I updated this files today 10/17/2016.
      For a little more detail the file:
      MD5:    34b58b743493bd908f10152c05ef7a42
      SHA1:    2cb0bc4ec499d143cecbfb484f9734ce6d53bd2d
      File size:    626.0 KB ( 641066 bytes )
      File type:    ZIP
      Please, try again.
  • Eng file is broken
    4 Posts | Last post October 12, 2016
    • Hi,
      It looks like the Eng version is a 0Kb file, the spanish version is ok though.
    • Hi Mark.
      I updated this files today 09/22/2016. The size of the file is:
      English version.
      | Name           | Size          |
      | Help.chm       | 636.687 bytes |
      | Icon.ico       |  32.038 bytes |
      | Info.txt       |     910 bytes |
      | Integrity.txt  |   1.310 bytes |
      | Launcher.exe   | 127.912 bytes |
      | License.pdf    |   6.062 bytes |
      | Readme.txt     |     631 bytes |
      | ResetWUEng.cmd |  28.128 bytes |
      | | 696.491 bytes |
      Spanish version.
      | Name           | Size          |
      | Ayuda.chm      | 637.607 bytes |
      | Icon.ico       |  32.038 bytes |
      | Info.txt       |     763 bytes |
      | Integrity.txt  |   1.332 bytes |
      | Launcher.exe   | 127.924 bytes |
      | License.pdf    |   6.062 bytes |
      | Readme.txt     |     655 bytes |
      | ResetWUSpa.cmd |  29.991 bytes |
      | | 697.777 bytes |
    • Dear Manuel,
      It looks the zip file of ENG version is still 0kb after download.
    • Hi,
      Problem solved. It looks IE can download the right file, but chrome cannot.
  • Caution
    2 Posts | Last post October 01, 2016
    • I'm hesitant to run your script since AVG identify Launcher.exe as
      Especially since your script requires elevated privileges (running as administrator).
      Can you describe Launcher.exe in a bit more detail, like who wrote is (is it you or 3th party), what does it do and why would AVG identify it as a trojan?
    • Hi dotnetCarpenter2,
      In the file "Info.txt" is described with a little more detail the file "Launcher.exe".
      Also, you can see in the comments information regarding this file.
  • Brilliant!
    2 Posts | Last post September 15, 2016
    • also works on 2008 R2 server -even though it detects as Win 7 :-)
      thanks for a great little tool.
    • Thank you!!
      It's correct, Windows Server and Home versions share some builds e.g.:
      Build 	5.2.3790
      Windows XP Professional x64 Edition
      Windows Server 2003
      Windows Home Server
      Build	6.0.6001
      Windows Vista SP1
      Windows Server 2008 SP1
      Build	6.0.6002
      Windows Vista SP2
      Windows Server 2008 SP2
      Build	6.1.7600
      Windows 7
      Windows Server 2008 R2
      Build	6.1.7601
      Windows 7 SP1
      Windows Server 2008 R2 SP1
      Build	6.3.9600
      Windows 8.1 Update 1
      Windows Server 2012 R2
  • Script Hangs at Failed to Stop Appl Identity Service
    6 Posts | Last post August 28, 2016
    • Manuel, I'm running Vista SP2 32-bit 6.0.6002. It halts Crypto, BITS, and Update Services, but returns an Open Service Failed 1060 when trying to stop the Application Identity service. I cannot even find the service in Vista. Is there a work-around, or am I doing something wrong? Gracias!
    • The BITS service, the Windows Update service, the Cryptographic service and  Application Identity service start with Windows and they came with old versions of Windows.
      Try to start the computer from safe mode and run this tool.
      To know more:
      ¡Qué tengas un feliz día!
    • I'll power up my Vista machine over the weekend and give it a try in Safe mode, but once again, I never did find an Application Id/appidsvc in its directory of services. Gracias.
    • I came up in Safe Mode, ran the script, and got the same result (Failed 1060 when trying to stop the Application Identity service.) There does not appear to be an Application Id service on my Vista. Gracias.
    • Hi bilvihur,
      I deleted the closure of the tool with the "AppIDSvc" for Windows Vista. Try again. Hopefully be resolved soon.
    • Thanks for getting back to me, Manuel, but in the interim I found a procedure which uses WSUS Offline Update to download ALL the appropriate Vista patches on my WIN 7 machine, copy them to a USB drive, and then install them on the Vista machine. It was time consuming, but now the Vista Windows Update works! Appreciate your help.
71 - 80 of 91 Items