List Contents of Tapes in DPM

Powershell Script to poll a DPM server and list the contents of all Tapes in the server. It can be tweaked or adjusted for more

 
 
 
 
 
4.5 Star
(4)
Add to favorites
System Center
3/24/2011
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Necro question but please help!
    1 Posts | Last post June 02, 2015
    • Is there a possibility to get the expiry date of the recoverypoint in this list?
      
      I have tried to add a =$Point..... but i cant find any ting for expirydate?
      
      can any one pleasehelp me?
      
      Other than this this script i great.
  • Using Task Scheduler for this script.
    1 Posts | Last post November 04, 2013
    • Thank you for the script, it was exactly what I was trying to build.  (Only one change, that was to add $RPSource=$Point.DataSource to get the source of the computer that the RP was on).  
      However, I'm having an interesting issue with it that I hope someone can help with.  When I run it from the DPM Management Shell, it works 100% of the time.  When I run it from task scheduler it works some times!  Most of the time, I get a csv file with just the headers.  Any thoughts?
  • source of RP
    2 Posts | Last post October 25, 2013
    • Hi,
      
      iam using your Script and i like it very well, iam looking for a small update, maybe you can help.
      I wannt to a one Information to my output, the Source of the Recoverypoint or the computer from which its taken, can you help?
      
      regards
    •  I found that $RPSource=$Point.DataSource gives me the source of the recovery point.
      
      
  • RP is a file share
    1 Posts | Last post May 06, 2013
    • How can I display the share, not just the drive?
  • I have a single stand alone drive
    2 Posts | Last post May 06, 2013
  • Error if the cleaning tape is library - sollution
    1 Posts | Last post December 31, 2012
    • Hi
      
      If you have the cleaning tape is in library the error: "Get-DPMTape : Parameter set cannot be resolved using the specified named parameters." For correct this error you must change line to
      
      $TAPELIST=$TAPELibrary | GET-TAPE | Where-Object { $_.Type -ne 'CleanerMedia' } 
  • Problem if you can in library new tapes
    1 Posts | Last post June 04, 2012
    • Hi,
      
      script doesn't work correctly if in tape library are new tapes.
      
      I've tried try/catch and if statement but I can't correct this.
      
      Do you can help?
      
      Regards