ConfigMgr Task Sequence Monitor

ConfigMgr Task Sequence Monitor is a GUI application that makes use of the task sequence execution data in the ConfigMgr database to review or monitor ConfigMgr task sequences.  It is particularly useful for monitoring OS deployment task sequences step by step in near real-time.

 
 
 
 
 
4.5 Star
(19)
20,515 times
Add to favorites
System Center
7/6/2017
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Exit codes
    1 Posts | Last post March 28, 2018
    • TS steps that accept non-standard exit codes and report successful show an error icon.
      Example is Dell CCTK commands that require a reboot, exit with a code 2, the TS accepts this as successful, but the monitor gives a red X icon for the step.
  • No results for active task sequence
    11 Posts | Last post March 16, 2018
    • Suddenly no results for active Task sequences are shown anymore. I can choose a tasksequence for the drop down menu, the running Client is in the list of the ComputerName field, but no actual results are shown.
      
      
      The tool worked like a charme for months, anybody else with this phenomenon ?
       
    • Have exactly the same problem. Anybody out there?
    • Same here. I've updated to 1710. Perhaps this is the issue?
    • Has anything changed in your SQL permissions? It's working fine for me on 1706 version.
    • Same problem here. No changes to the SCCM database permissions. Has anyone fixed this?
    • Same problem here in some new TS. (copy from old TS)
      Old TS working OK 
    • When I delete TS and create new copy it works...
    • Got the same issue today, blank in TS list. I quess this is aftr latest 1710 patch in SCCM.
      
      Any ida what i can do to get it working?
    • Same here. After 1710 it down not Work
    • Three months passed, and still the same Problem, no results. It would be very Kind if the developer could give any hint how to troubleshoot this Problem.
      It's frustrating to have Tools and scripts in the TechNet Gallery that don't work at all. Everybody is wasting so much time
    • I am sorry you are experiencing this issue, but I can not replicate it. Everything works fine for me in 1710. I can only imagine SQL permissions have changed somehow after upgrading. Without more information on the environment where this issue exists it’s difficult to troubleshoot. Feel free to reach out to me via my blog with more information on your environment /SQL permissions. smsagent.wordpress.com.
  • Picked up as Malware
    5 Posts | Last post November 10, 2017
    • As of today the ConfigMgrTSMonitor.exe started to be picked up as Mal/Mdrop-KT and reported by 11 AV vendors as containing malicious software on virustotal.com  We use Sophos and it is quaratining/deleting the exe.
    • And I just saw the latest updated and realized I have the older version.  Sorry for the post.
    • And the new 1.6 version is causing the same issue.  On file ConfigMgr_TS_Monitor.exe
    • I have contacted Sophos to whitelist the executable.  Waiting for a response...
    • Got the following response from Sophos. Hopefully it won't be quarantined anymore.
      SophosLabs has analyzed the submitted file(s) and determined they are not malicious.
      •	ConfigMgr_TS_Monitor.exe -- clean
      •	0b688da1-fe84-4305-a850-6e~.ps1 -- not detect worthy at this point in time
      •	ConfigMgr_TS_Monitor.exe.zip -- archive file
      
  • broken installer?
    2 Posts | Last post November 09, 2017
    • I think the installer may be broken... it creates a shortcut to"C:\Program Files (x86)\SMSAgent\ConfigMgr Task Sequence Monitor\ConfigMgr_TS_Monitor.exe" but the .exe file does not exist..?
    • Probably quarantined by AV.  Which AV vendor are you using?
  • Cannot Download, shows as virus
    2 Posts | Last post November 09, 2017
    • I cannot download the utility.  It shows as a virus.
    • Which AV vendor are you using?
  • Not Functioning
    2 Posts | Last post November 09, 2017
    • I had my DBA team add my login to the role of "db_datareader" on my sccm db.  I log into my sccm server where I like to run the monitoring tool, installed the new 1.6 version, run as admin, configure, says it connected to sql, but none of the task sequence list drop downs have anything in them.  What am I missing for setup?
      
      sccm 2012 r2 sp1 (5.00.8239.1000)
      sccm server is windows server 2012
      sql server is windows server 2012
      the account I log into them with is a domain admin and all around sccm admin but i have limited rights to databases which is why I had dba team add my login to db_datareader role.
      
    • How many active task sequences do you have in your environment?
  • install Config switches?
    2 Posts | Last post November 06, 2017
    • Hello,
      
      Is there any way to package this as an application, and specify our server settings within the install command?
    • Not currently, sorry.
  • There are no Task Sequences in the drop down box at all
    1 Posts | Last post September 21, 2017
    • Hi Trevor,
      
      This tool sounds awesome, but I can't get it to show any Task Sequences.
      
      I entered our SQL server and DB in the settings, and I get "Connected to SQL Server database.  Select a Task Sequence." in the action output window, but there are no Task Sequences in the drop down box at all.
      
      Powershell 4
      .NET 4.5
      User account has db_owner rights on the SCCM DB
      Also, there are about 12 deployed before
      I do not have MDT installed.
      
      I have ran SQL query & get output from it in "SQL server Management Studio":
      
      SELECT DISTINCT summ.SoftwareName AS 'Task Sequence'
              FROM vDeploymentSummary summ
              WHERE (summ.FeatureType=7)
              ORDER BY summ.SoftwareName
      
      User have SQL Roles: Public & Sysadmin
      User have User Mapping roles for SCCM DB: dbo,db_reader,db_securityadmin, public, other "sms" permissions.
      
      Any idea why it's not working?
      
  • No Task Sequences Appear Redux
    7 Posts | Last post August 04, 2017
    • I have the same issue stuart.macdonald reported. I get a message confirming a connection to the database, but there are no task sequences listed. I too do not currently have MDT integration.
       
    • Do you get results if you run the following SQL query against your ConfigMgr database from the same machine? 
      
      SELECT DISTINCT summ.SoftwareName AS 'Task Sequence'
              FROM vDeploymentSummary summ
              WHERE (summ.FeatureType=7)
              ORDER BY summ.SoftwareName
      
      You can find a script for running a SQL query with Powershell on my blog: 
      http://smsagent.wordpress.com/2014/09/17/querying-configmgr-wmi-vs-sql/
    • grant select permision to vDeploymentSummary solved this problem
    • All the sudden I have this issue where it says it connects to the db but no task sequences show up. This tool has been running great for months and now all the sudden nothing. 
    • Hi,
      
      I go SCCM CB 1702 and have the same problem. No task sequences on the list available from the tool.
      I got rights of reading on the database. The tool tell me on the bottom : "Connected to SQL Server database.  Select a Task Sequence."
      But nothing on the list.
      
      So i tried the query : SELECT DISTINCT summ.SoftwareName AS 'Task Sequence'
              FROM vDeploymentSummary summ
              WHERE (summ.FeatureType=7)
              ORDER BY summ.SoftwareName
      
      directly from the server and got results.
      What can i do for troubleshooting ?
      
      thanks
      
    • i tried the powershell script with SQL and finally, it was an issue of permission of my AD account . I logged on a admin user then, here we go ! list of TS :)
      Now, i have another problem, i choose a TS but no result appear. It's a build and capture TS. Is it normal ? thanks
    • if nothing appear, i just need to change "Time Period" for an upper value ... sorry everthing works fine. Great Tool !!! Amazing :)
  • I'll paypal you to fix this trojan nonsense
    4 Posts | Last post April 20, 2017
    • I'll throw you 100 on paypal if you can come up with a solution that does not make this application come up as a virus.
      
      I know its not much but I truly miss this thing and I only was able to use it for 2 days. 
    • Now there's an offer I can't refuse! Can you drop me a message via my blog (http://smsagent.wordpress.com/about/) and I'll create a new installer file for you. If this works for you, I will update the version here.
    • Still working like a champ. I use it everyday. Well worth the donation. 
      
      Now what about the custom error codes and unknown computer names fixes =). I'm neurotic and would love to see zero errors every time I run this on a collection. I hate the cringe seeing errors when they are actual successes. 
    • Just started work on that for the next release.
11 - 20 of 35 Items