ConfigMgr Task Sequence Monitor

ConfigMgr Task Sequence Monitor is a GUI application that makes use of the task sequence execution data in the ConfigMgr database to review or monitor ConfigMgr task sequences.  It is particularly useful for monitoring OS deployment task sequences step by step in near real-time.

 
 
 
 
 
4.5 Star
(19)
23,537 times
Add to favorites
System Center
7/6/2017
E-mail Twitter del.icio.us Digg Facebook
  • Status text is omitted (possible missing)
    3 Posts | Last post February 22, 2016
    • Hi again TrevorJones,
      
      It seems like some of the Action Output text is being omittet or somehow missing text.:
      It's not a big deal, but i'm guessing it's not intended.
      
      [This is first line in a Install Update step (see the ... 9 (it's like somthings missing))]
      ... 9-41db-9b21-734ea9558bdf:version=205'.
      [789] Added/updated setting 'ccm_civersioninfo:modelname=site_e41a98bf-4d39-4aec-a950-
      [.... TEXT OMITTET BY ME AS]
      ProcessID = 3348;
      ThreadID = 3352;
      ;
      
      uccessfully submitted event to the Status Agent. [In this line "s" is omittet]
      End TS policy evaluation
      Policy evaluation initiated
      [REST OMITTET BY ME]
      
      [Install Application Step, same behavior first line 3 dots and some text missing]
      ... essID = 3288;
      ThreadID = 3672;
      ;
      
      uccessfully submitted event to the Status Agent. [After space "s" is missing]
      End TS policy evaluation
      
      [Another install application step]
      ... tedConfig for source CcmTaskSequence successfully
      
    • Hi, this is not an issue with the application but it is how ConfigMgr stores the data in the database.  As far as I've been able to tell, the action output is a snippet from the smsts.log relating to that action, but it does not contain every entry in the log.  Basically whatever is in the database will be displayed by the tool, even missing first letters!
    • allright, just seemed odd.. :)
  • double posts
    5 Posts | Last post February 22, 2016
    • Hi Trevor,
      
      I've noticed that each action is shown twice.
      I've checked with 2 customers and it's the same, every step is shown 2 times.
      
      Can you see this?
    • Hi, yes I have seen this where a computer was recently deployed and is being redeployed again.  I haven't had time to investigate yet though.  In what scenario do you see this?
    • Background: I have 2 Task Sequence, one DriversOnly, and a Production. The drivers only stops when os has been installed and configmgr client, then it open devmgmt.
      
      Today I first run a machine with DriversOnly, saw that every driver was ok.
      Reinstalled the computer with Production TS, and from the log every entry was double. So it has not run this TS before.
    • Gotcha, so the machine is being deployed twice though using different task sequences.  I did some investigation and found that a couple of the SQL queries appeared to be duplicating the results because the machines have more than one mac address.  Anyhow, I just uploaded version 1.4 where the issue should be fixed.  Please give it a go!
    • It seems to be resolved
  • Timestamp 1 hour off
    6 Posts | Last post November 23, 2015
    • Hi, great tool.
      I have noticed that the timestamp is one hour off (less) than my actual time.
      I live in DK, is this something you could consider look into.
      
      Also, would be great if it was visible in the taskbar, instead of minimizing all other windows.
    • In which part of the app is the timestamp off for you?  Once you've clicked on the app, it is visible in the taskbar as a Powershell icon.
    • MDT monitoring always uses UTC and it seems that ConfigMgr does the same for the execution time.
      
      https://social.technet.microsoft.com/Forums/en-US/96dce07e-cbeb-4ae1-aa37-a6f602976fe1/monitoring-in-mdt-2012-time-zone-issue?forum=mdt
    • Ahh ofc.. didn't look for powershell as it was allready pinned. Was looking for the icon..
      
      okay, so theres nothing to do about the time?
    • Yeah I'm sure it's possible to add an option to convert the date-times to your local timezone.  Thanks for the suggestion...something for a future release!
    • Ok, it's your lucky day... I just added the capability to display dates in your local timezone in v1.3.0 ;)
  • Task Sequence ComboBox isn't populating properly...
    3 Posts | Last post November 20, 2015
    • I have a strange issue where the Task Sequence ComboBox is listing the Task Sequences Vertically - one letter of the Task Sequence per entry in the Combo Box.
    • That could happen if you've only one task sequence in the list.  The app assumes you have more than one task sequence.  If there is only one, it will not display correctly as it doesn't interpret as an array but a string - I will make a note to correct that in a future version.
    • Now fixed in v1.2.2 :)
  • Can't start the application
    11 Posts | Last post November 20, 2015
    • Hi,
      
      The application looks great but I can't get it to run. Tryed on 2 Win 7 x86 client and a Server 2008 (ConfigMgr Primery site server) as well but it just flash briefly and turns immediately back down. 
      
      Powershell version: 3
      .Net: 4.5.1
      ConfigMgr 2012 R2 SP1 CU1
      MDT 2013
    • Yup - me too.  Installs ok, but when starting (as admin or not) it just flashes up a window then quits.  Nothing in the event log.
      
      Win7 Enterprise x64/x86 and WinServer 2012 R2.
      SCCM 2012 R2.
      .Net 4.5.1 and .Net 4.6
      MDT 2013
      
      Tool does look great though.  Looking forward to using it!
    • Have the same issue
      
      Windows Server 2008 R2/Windows Server 2012 R2
      PS Version 4
      ConfigMgr 2012 R2 CU1 / ConfigMgr R2
      .Net 4.5
      MDT 2013
    • Same issue, tool opened then close itself. 
    • I have the same issue too.  It appears to be a DCOM error.  I tried to change the permissions using some 'googling', but still have the same problem.
      
      The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID 
      {D63B10C5-BB46-4990-A94F-E40B9D520160}
       and APPID 
      {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
       to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
    • Regarding the DCOM error, does it work if you try this:
      http://xlery.com/blog/2014/04/16/windows-8-1-event-10016/
    • No manipulating dmcom permissions doesn't seem to do the trick 
    • Hi Trevor, yes I agree with Haplo.  I tried these steps from a different blog post, but it didn't make any difference (although the events stopped being logged in eventvwr)
    • Same here but it look like it can't connect to the sccm database I get an error in the eventvwr:
      
       "Login failed for user 'username'. Reason: Could not find a login matching the name provided. [CLIENT: 172.17.1.46"
      
      I am database owner so should have no problem connecting
      
    • Hi, I fixed a small bug in the code, please download the latest version.  Thanks!
    • Thanks Trevor.  It appears to be working now.
  • Tool launches and then immediately exits..
    5 Posts | Last post November 19, 2015
    • Please let me know how I can help?  what diagnostic information can I provide?
    • Hi, I fixed a small bug in the code, please download the latest version.  Thanks!
    • OK download the new version but cant find the settings button, I have a very limited display resolution on the remote server and I cant see all the controls and buttons.
      
    • Got it working, Thanks very much. 
    • Yeah, minimum resolution 1366 x 768 recommended!
31 - 36 of 36 Items